Multisite Sub site pages are not applying header or page CSS

Multisite Sub site pages are not applying header or page CSS - Primary site is working fine but any subsites pages I have to add the css to the global css or it doesn’t take effect

as an example see the bottom red footer - privacy policy & terms link has some css styling added to the a footer.css which takes affect on the primary site but not on subsites. If i add this css to the global css it works fine… so far page.css, footer.css and header css on the subsites isn’t applying. Also haven’t been able to confirm this but it maybe only breaking at certain break points.

Hi @etahross,

Thanks for reaching out!

There could be a plugin or custom code that affects your website.

I recommend the following troubleshooting procedures before we investigate the settings.


Only if none of that helps, please give us the following information in a Secure Note.

  • WordPress Login URL
  • Admin level username and password

You can find the Secure Note button at the bottom of your posts.

Thank you.

Ok I have done most of the above… On my staging site

Disabled child theme
Disabled all plugins
Cleared all caches
Using latest pro theme version
No javascript
Cleared browser cache

OK so when using this css in page css

.list-features li a {color:white; text-decoration:underline;}
.list-features li a:hover {color:rgb(199, 0, 0); text-decoration:underline;}

styling of list at larger widths is wrong

But then at smaller device width the styling seems to apply

also if i add the above CSS to global CSS styling applies correctly. Ie link gets underlined and is white not red

Please note this only affect sub site pages not the primary site page.

I’m sure this wasn’t happening before updating the theme with the lastest round of updates.

Hi @etahross,

I have investigated your site and found that the style for a tag has been already defined. You need to add the !important to the CSS attributes to override that through your custom CSS code

.list-features li a 
    color:white !important; 
    text-decoration:underline !important;    

Please remember that the above code will work if copied as it is and doesn’t conflict with any existing style.
Please note that the code provided serves only as a guide to help you get started custom coding on your own if there’s no option offered in our theme or the products we bundle.
We really do not provide support for custom codes that means we can’t fix it in case it conflicts with something on your site nor will we enhance it.


I’m not sure you read posts earlier in the thread… The problem isn’t with what CSS I am applying… the problem is that no CSS is applying when it is entered into header CSS, page CSS or footer CSS if the page is a subsite page … it only work when added to global CSS or in the primary domain.

And even when I add the code you suggest to page CSS on my subsite page it does no apply. But it does work on page CSS on any primary site page.

And yes i know i can get the CSS to work if its added to global CSS but that’s not the point, something is not working properly with your theme on subsite pages when entering CSS to page level CSS. I don’t know how many times you want me to say it. This only changed when the theme updated lately.

Hi @etahross,

Sorry for any confussion. I went ahead and tried to check the issue by logging into one of your subsites, but it does not allow me to do so.

I would suggest you provide the proper credentials for further investigation.

Ahh Ooops… fixed the login.

Hello Lain,

I have logged in and I found this broken CSS in your sub site global CSS which is in Ruffnuts Dashboard > Cornerstone > Theme Options > CSS:

@media (max-width: 766.98px){
.toplinks {
    font-size: 0.8em;

Screen Shot 2021-09-06 at 7.11.57 AM

The correct code should be:

@media (max-width: 766.98px){
  .toplinks {
    font-size: 0.8em;

Please have it updated because this is what is causing the issue. If you have inserted this code also in your Main site, you will need to go to Main Site Dashboard > Cornerstone > Theme Options > CSS and update it as well.

Kindly let us know how it goes.

Thank you very much… worked perfectly.

Awesome theme… Awesome support.

You are most welcome, Lain!

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.