Multisite redirection issue

Hi there,

Short video to explain it better: https://youtu.be/LB2gd_yn_y0

I’ve set up a WP multisite environment with pro:

http://bigfish.ethermedia.hu/
http://bigfish.ethermedia.hu/bigfish-lanchid/

Here, the links work fine.

However, I’m trying to upload this to a live URL:

https://thebigfish.hu/

and

https://www.thebigfish.hu/lanchid

One difference I noticed is that the live URL has SSL, I don’t know if this can cause the issue, but here’s whats happening:

The homepage loads fine, but whatever child URL I try to load for:
https://thebigfish.hu/lanchid/

For example https://thebigfish.hu/lanchid/etelek/
It redirects me to the https://thebigfish.hu/andrassy/etelek

This happens on all sites.

Any ideas what can cause this?

UPDATE:

I managed to fix it with this in my installation:

BEGIN WordPress

RewriteEngine On RewriteBase /lanchid/ RewriteRule ^index\.php$ - [L] RewriteCond %{REQUEST_FILENAME} !-f RewriteCond %{REQUEST_FILENAME} !-d RewriteRule . /lanchid/index.php [L]

END WordPress

In the htaccess file, however, now I can’t access the PRO editor since it asks me to log in each time.

Hi @Pbalazs89,

Thanks for reaching out.

I tried a similar setup but I couldn’t find what’s causing it, and it shouldn’t require that rewrite since it’s installed at the same folder.

Is it an actual sub-folder installation or Wordpress’ multi-site configuration? If it’s a separate installation on a subfolder, then you should let your sub-installation generate its own htaccess by going to Admin > Settings > Permalinks. If it’s a multi-site configuration then that’s the problem as the requests are redirected through rewrite and nonce as part of security, only works on the same URL origin.

Another possible cause is HTTPS, not all requests are served through HTTPS causing conflict. And with that, session will expire and will log you out. I recommend fixing the URLs to HTTPS and test it again.

Thanks!