Mobile menu conflict after updates


After the update of X and Cornerstone my menu in mobile devices is down. Loading the webpage in a mobile phone the front page is okay, but touching de the menu and clicking one of the child pages the layout ( stack Ethos) is gone. The webpage shows fine in Desktop and iPad.

The first image shows the normal correct layout of the front page, the second shows when clicking a child page within the menu.

I can’t figure it out what is wrong, so I hope you can help me out.

Hello Ingrid,

Thanks for writing in! I have checked your site and I could not see the menu.
Did you happened to remove it?

By the way, I noticed that you are using WP Fastest Cache. And because of this, right after every them, plugin updates or any slight site changes, always clear your plugin cache before testing your site.

Hope this helps. Please let us know how it goes.

I am used to clear cache with every change. Until recently the website worked fine. After the update of Cornerstone and X the mobile menu doesn’t load the Ethos stack. The website is working fine on desktop and iPad. There is a menu attached, of course, I don’t understand why you can’t see the menu. I have checked the website on many mobile devices and in three browsers; Google, Google Chrome and Firefox. All gave the same result. Not loading Ethos stack when clicking the menu.

As you can see in the former attached images, the index is loaded correct but when clicking the menu the child page is shown with blue header and the Ethos stack is gone.

  • I deactivated all my plugins and cache plugins, no result
  • I have not deactivated Polylang plugin because of loss of data

I will send you my credentials and really hope that you can solve this problem.

Thanks in advance,

The website is down now. White screen shows on desktop version and ipad.
Could you please take a look what is going on?


It’s been a while since my last question. Because I did not receive a reply I have searched for a solution.This fixed a part of the issue. Deactivating one of the plugins removed the code in .htaccess file.

BEGIN WordPress

RewriteEngine On RewriteBase / RewriteRule ^index\.php$ - [L] RewriteCond %{REQUEST_FILENAME} !-f RewriteCond %{REQUEST_FILENAME} !-d RewriteRule . /index.php [L] # END WordPress

The website seems to be fine now but clicking the posts in the carousel of the Ethos stack, the post carousel is gone and shows a white space.
Hope you can give my a solution for this issue.


Hi There,

You’re not fully updated with regard to X theme & Cornerstone. For X theme you’re one version behind and for Cornerstone you’re few versions behind. Please make sure that you’re fully updated (simply disable/delete your Cornerstone plugin and head over to X -> Overview section to install the latest version) and then test your site again.


Hi, thank you for the answer. When you viewed the web page is was migrated to another server and I had to do a back-up. I have followed your instructions. The website is working fine now, but I am facing another problem with the latest updates of X and Cornerstone. When loading a web page in the back-end with Cornerstone it gives a conflict, “page could not load due to iframe responce being incomplete. This is most often related to a plugin conflict or customizations introducing a PHP error” Please note I have not added new plugins.


Hi There,

I tried to login to your website but the password does not seem to be working any longer.

Please refer to:

Let us know how it goes

Thank you

I solved the issue regarding Cornerstone:
The message while loading Cornerstone “page could not load due to iframe responce being incomplete. This is most often related to a plugin conflict or customizations introducing a PHP error”

-I asked my hosting company to set the PHP version from 5.6 to 7.
-The max_excution_time was raised from 30 to 500
-In the wp-config.php they set the memory limit to a higher level.
-I deactivated all my cache plugins.

Cornerstone in de latest updated version is running now.

thank you for the support.



Glad to hear it Ingrid!

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.