Mobile dropdown issue


I have a couple of navigation issues on

  1. I have set up a collapsed navigation for mobile view. I set the sub menu trigger for ‘indicator’ but it’s not working. I cannot get the menu to open. If I change it to ‘anchor’ the dropdown opens of course, but then you can’t navigate to the main link.

  2. On iPad landscape, the regular inline menu shows. BUT, you can’t click to visit the main link. Only the dropdowns pop out. This is working fine on desktop.

How can I fix these 2 issues? Happy to provide a login.

Hi @Lorenmn,

Thanks for reaching out!

I m not able to replicate the issue on your website because it is password protected. Would you mind sharing the password or the admin credentials in order for us to check the issue? To do that, please give us the following information in a Secure Note.

  • Password (website coming soon)
  • WordPress Login URL
  • Admin level username and password

You can find the Secure Note button at the bottom of your posts.

Thank you.

Hi @Lorenmn,

It seems that you are using a little older version of Pro. I would suggest you update it to the latest version i.e. 4.3.3 and check if that issue still exists or not.


Hi. I’ve updated but I’m still having the same navigation issues.

Hello @Lorenmn,

I have checked your site on my android phone and I could not replicate the issue.
Please check out the screenshots below:

You may need to clear the browser caches on your phone or use private browsing mode and test the site again.

I’ve cleared the cache on my iPhone and it’s still not working. In fact, even if I touch the burger menu icon, it doesn’t always open.

Additionally, I still have the problem (no. 2 above) on iPad.

Really need to fix these.

Hi @Lorenmn,

I have checked the website in the iPad using the online browser testing tool and browser device tool and didn’t found the issue you described. Can you please provide any video that helps us to recognize the problem?


What online browser testing tool and what browser device tool did you use? The one’s in the X preview don’t replicate properly. The problems remain.

  1. iPhone - the dropdowns do not show regardless of whether you click the parent category or the indicator. I have a video but don’t know how to send it. It’s MP4. However, I don’t know how that’ll help - but shows that the dropdown doesn’t appear.

  2. Ipad (landscape) - the full inline menu shows and clicking the parent category actions the dropdown to appear but NOT to visit that main link.

So, still not working…

Hey @Lorenmn,

  1. I’ve replicated the issue and it’s because the sub-indicator area is very small so your finger needs to accurately land on that very small tap area. I’ve tested increasing the sub-indicator size and I could now open successfully.


  1. This is normal. On a mobile device, you only have 1 action and that’s to tap. On desktop, there are 2 actions and those are “click” and “hover”. The Navigation Inline dropdown mobile equivalent of hover is the tap. That might sound weird but like your issue with the sub indicator above, the area would be very small if link click and dropdown open is allowed so there’s no Sub Menu Trigger unlike the Navigation Collapsed.

A solution to that iPad problem might be creating a Mega Menu. Watch the video below to learn more.

Hope that helps.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.