Microsoft Edge Not Showing Images


My website images/icons are showing on most web browsers, but not for Microsoft Edge? On the homepage link above there is a “Slider” element to the left that will not display images. And just under that, there are “Feature Box” elements that will not show icons.

Hi There,

Please try to update Pro theme. See latest our changelog here and latest versions here. Since X Pro is now Pro, you have to manually reinstall the theme. Deactivate current theme X Pro and then from your themeco dashboard download latest Pro and install it.

Let us know how this goes.

EDIT: All of my settings stayed the same even with installing the latest version of Pro and my images are showing in the Microsoft Edge web browser.

Glad that you managed to fix the issue :slight_smile:

Hi there,

I have the same issue. Microsoft Edge does not show the image (logo of opto biolabs) in the header, but chrome does:

I’m using the Pro version 2.2.5 and never had anything else installed from Theme co before.

What can I do? Thanks in advance.


Hi @optobiolabs,

It does look like a browser glitch, just toggling off and on a styling makes the logo appear. Would you mind starting a new thread about this issue and provide your login credentials in a secure note? I like to test the styling and we recommend provided credentials in your own thread for security reason.


Many thanks for the reply. I opened a new thread here: