Metaslider Links not working with Pro Child theme

Before I created a child theme, the Metaslider on our site was working (first image has no link). But after I activated the child theme, the links stopped working. The style.css file is empty except for the authored by and version comments. I can’t seem to post the contents of the functions.php file correctly - no code formatting option? But all it did was look for a specific category and add a block of text before the posts on the category archive page. This works.

Why would this cause the links to stop working? I’ve emptied the entire functions.php file and it still doesn’t work. Switch back to the main Pro theme and it works fine. What am I missing?

Hi Stephen,

Thanks for reaching out!

Maybe you have made some customization in your Child Theme that’s why the meta slider is not working. I suggest that you review the files in your Child Theme. You can also check our default child theme below.

Hope that helps.

Thank you.

Hello @marc_a, I’m not sure you understood what I wrote.

The child theme contains only a functions.php file and the empty CSS file. The Metaslider doesn’t even work when the functions file is emptied. There are no additional files within the child theme.

I just tried using your child theme and I get the same result. It doesn’t make sense.

Hi Stephen,

Would you mind sharing your admin credential so that we can take a look at your back-end? To that, please give us the following information in a Secure Note.

  • WordPress Login URL
  • Admin level username and password

You can find the Secure Note button at the bottom of your posts.

Thank you.

Hi Stephen,

Unfortunately, the given credentials are not working. Can you please check and send it once again.


Done - missed a letter on the pwd.

Hi Stephen,

I just check your website and the child theme is activated then I found that there’s a small area of link at the bottom of right corner. I am not quite sure what’s going on but it is just working with the parent theme. Please keep in that the meta slider plugin is not listed on our supported plugins and also same goes with the child theme customization. I suggest that you remove your child theme and download the child theme from the link I posted above then let see if the issue still persist.

Thank you.

The child theme that you saw was your’s though it seems it was cached. I uploaded instead of using FTP and now it’s in place and active. Same result. I see the link you’re speaking of but I don’t understand how a child theme with no actual customizations could affect the metaslider in this way.

Hi Stephen,

I had investigated the issue and yes it is weird, there is nothing on the child theme that can affect the plugin and I see that you already deactivated all other plugins, so more likely this is a bug with the MetaSlider plugin not honoring a standard child theme. Please contact the MetaSlider support instead.


This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.