Main portfolio page missing images

On the main portfolio page there are no images - only text / title. Where did all the images go?

Hello @PR10,

Thanks for writing in!

Your images were not showing because there is a CORS (Cross Origin Resource Sharing) issue in your site. This means that the images were loaded from another site and not from your current domain. Did this happened after you have migrated from your staging site?

To resolve this, please install Better Search and Replace plugin. Do a search for the keyword and replace it with the new keyword. Please see the secure note.

Please let us know how it goes.

I installed and ran the plugin “Better Search Replace” with the urls in the secure note and it came back with:

DRY RUN: 51 tables were searched, 0 cells were found that need to be updated, and 0 changes were made.

I also deleted the portfolio image and re-uploaded it and still doing the same thing. I am using GoDaddy managed wordpress hosting and they give an automated 1 click staging staging environment. So no, we did not migrate, but maybe the GoDaddy staging environment seems like a migration to wordpress?

Hello @PR10,

Would you mind providing us the url of your site with login credentials so we can take a closer look and fix the issue? This is to ensure that we can provide you with a tailored answer to your situation. Once you have provided us with your URL, we will be happy to assist you with everything.

To do this, you can create a secure note in your next reply with the following info:
– Link to your site
– WordPress Admin username / password

To know how to create a secure note, please check this out:

Thank you.

OK - I’ll add secure note - thanks

Hello @PR10,

I have checked every thing and even did a search and replace. The image url still not changing. It seem that there is a script from your host or something. If there is a CDN settings in your hosting, then that might be the cause of this issue.
Perhaps this links could help you:

Or maybe there is a setting in your GoDaddy account that the CDN can be turn off so that the images will be serve from your site’s domain and not from CDN. Would you mind giving us some access to your hosting account so we can check it?


I turned off the CDN and flushed the cache in GoDaddy. I didn’t seem to solve the problem.

Hi @PR10,

Please remove that custom CSS below from your Theme Options > CSS, that is the code that hides the featured images on pages.

.page .entry-thumb {
  display: none !important;

If you don’t want pages to show a featured image, please do not add a featured image to your page or use the Blank - No Container | Header, Footer page template.

Hope it helps,

That did it - thank you. As always you guys give great support which is why I use the X-Theme on all my projects. Outstanding work and thanks again. You guys rock!!

You are most welcome. :slight_smile:

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.