Logo and header menu static with Renew


I am having a hard time getting the header and logo to stay at the top of the page. I don’t want it to be fixed top - I want it to be static. I tried changing position to static in theme options, but it doesn’t seem to be working.


Hello Darien,

Thanks for writing in!

This is the documentation for the navbar position settings. You can find this in X > Theme Options > Headers.

Can you please clarify what you want to do? To better assist you with your issue, kindly provide us access to your site so that we can check your settings. Please create a secure note with the following info:
– Link to your site
– WP login URL
– WP username
– WP password
– WP Administrator Role

To know how to create a secure note, please check this out: How The Forum Works

Best Regards.

Ok, I added a secure note.


Hello Darien,

Thanks for providing the information. You are having the issue because you have added this custom CSS in Appearance > Customize > Additional CSS:

.masthead.masthead-inline {
   position: fixed;
   z-index: 9999;
   width: 100%;
   top: 0;
   background: transparent;

And you also have added this code in X > Theme Options > Custom CSS

/* NAVBAR */
.home .x-navbar {
/*     background-color: rgba(0,0,0,0.25) !important; */
    position: static;
    width: 100%;

Kindly remove this CSS codes so that the setting in X > Theme Options > Header > Navbar will work.

Kindly let us know how it goes.

I see, thank you. Well, I’m trying to get the menu on top of the slider and stay at the top. How do I go about doing that?

Hello Darien,

Please edit the page and reassign the slider. Instead of having it above the masthead, you will have to assign the slider below the masthead. You can all do that in the Slider Settings. To know more about the slider can be assign in the masthead, please check out this documentation:

Hope this helps.

That worked, thank you! Now, I am trying to make the menu transparent. I used this code:

.x-navbar {
background-color: transparent !important;

It doesn’t work though. I tested it with red, yellow, and blue and those work just fine…

Hi Darien,

It seems that you need to check out this thread instead:

Hope this helps.

That fixed it, thanks a bunch for all your help.

You’re welcome Darien!
We’re glad we were able to help you out.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.