Lightbox video won't open in Essential Grid

About 18 months ago I built my video portfolio gallery on my site using Essential Grid. It worked perfectly, with video thumbnails playing on hover and the linked Vimeo video opening in a lightbox when you clicked on a tile. A few weeks ago a prospective employer told me that the videos in my gallery don’t play.

Here’s the portfolio page. It used to be when you clicked on a thumbnail a lightbox would open, now nothing happens.

Here are my post fields, grid settings, and skin settings:



I’ve searched the forums, read the ThemePunch article, and followed the video tutorial step-for-step. Nothing helped. Any ideas?

Hey @one_eyed_man,

Thanks for writing in!

I have inspected your site and I am seeing an error on the console:

Uncaught TypeError: jQuery(...).find(...)[0].trigger is not a function
    at HTMLDivElement.<anonymous> (esg.min.js?ver=3.1.1:12:42483)
    at HTMLDivElement.dispatch (jquery.min.js?ver=3.7.1:2:40035)
    at v.handle (jquery.min.js?ver=3.7.1:2:38006)

I noticed that you are using Siteground. Did this issue happen after you have updated the site? Please log in to your SiteGround account and purge your site cache because there is a caching feature on that hosting.

Best Regards.

Thanks for the response @ruenel. I just logged into Siteground and purged Dynamic Cache and MemCached but the issues persist.

I just noticed that the videos tiles on my homepage are acting up as well. I’m using the standard Grid element for those. When I click a thumbnail a lightbox opens, but it’s empty (it’s supposed to play a Vimeo video). I tested that a few days ago and it worked fine.

Do you think this has something to do in with the ACF Pro plugin? It’s a common element in both my homepage Grid and Videos page Essential Grid.

I did update some plugins today, but the Essential Grid issue started before I updated anything.

Hi @one_eyed_man,

I have checked and found that the width of the Modal is set to auto which is the reason behind your problem. I would suggest you set any value to width and check if that works for you or not.
Please remember to clear all the cache after changing the value to get the updated value set to modal in the browser.

Hope it helps.
Thanks

@tristup thanks for that, it fixed the videos on my homepage. The lightboxes on my Videos page still aren’t working - could you take a look at those please? Details are in my first post.

Hi @one_eyed_man,

I have checked the video page but the videos are not clickable and no modal is coming up. Can you please explain the issue you are facing on this page?

Thanks

Hi @tristup, it’s an Essential Grid issue, could you read my initial post please? The modals on that page used to work fine when you clicked them but sometime in the last couple months they stopped working.

Hi @one_eyed_man,

Sorry that I have missed out on the point. There might be some different reasons behind your issue, I would like to suggest troubleshooting the following common issue to help us to recognize the reason.

1.Theme Related Issue
2.Plugin Conflict
3.Theme Update related issue
4.Child Theme Related issue
5.CSS/JS Customization
6.Disabling Cache
7.Disabling CDN

If you discover that an issue is coming from a custom code or 3rd party plugin, kindly consult with a developer or contact the plugin author. Please note that we do not provide support for custom codes and 3rd party plugins.
If none of the help, please copy your live site to a staging server so we can troubleshoot freely without breaking your live site.
And give us access to the secure note including:

– WordPress Site URL & Login URL
– WordPress Admin username/password

To create a secure note, click the key icon underneath any of your posts.

Thanks

@tristup I went through the recommendations in the articles but the issues persist. I tried to set up a staging server but my Siteground plan doesn’t allow that:

You are welcome to troubleshoot on my live site, I have backups. My login info is in the secure note attached to my first post.

Hi @tristup, any update on this?

I would reach out to ESG as it seems like something in their JS files related to what Runel said originally. The only thing I could determine is it’s erroring out trying to find a button with this class .eg-invisiblebutton, but that class is on the page. I can only guess that they changed structure of their layout and now it can’t find the eg-invisiblebutton. Turning on SCRIPT_DEBUG in wp-config.php will probably help them as well determine what’s going wrong.

// Use dev versions of core JS and CSS files (only needed if you are modifying these core files)
define( 'SCRIPT_DEBUG', true );

Copy that, thanks @charlie, I’ll reach out to them with that info

You are most welcome, @one_eyed_man.