License issue with new site

Hi, I decided to reset my wordpress site and start over, however when I try to use my license again it says it doesn’t seem to be a valid purchase code from themeforest. I tried to “unlock” the license here on my account with themeco but it still doesn’t work. What can I do? How can I “reset” the theme validation code so I can use it on my new site?

Hello Daniel,

Thanks for writing in! I have checked your license and it seems that it has been assigned to an incorrect url. ​To validate X properly, please do the following:
1] Please login to your account ( and assign the license. You need to assign the license to your site using this url: You have to make sure that url you just assign is the same as the one you have in your settings, Settings > General > Site Address
2] Go back to X > Validation, and insert the license code.

And please review the changes that we made on how you are going to validated your X theme because we made a big change in the process. Please check it out here:

Hope this helps. Please let us know how it goes.

No, I’m sorry but I can’t make it work. It still gives me an error message after I’ve assigned it to the web adress like you said.

Hello Daniel, is meant to be replace with your own domain name.
Are you trying to validate the site I posted in the secure note? Please create a secure note and insert your WP credentials when you reply so that I can validate your theme for you. To know how to create a secure note, please check this out:

Thank you in advance.

I’ve attached a secure note to the thread.

Hi Daniel,

Thanks for providing the information. It turns out that X theme is not active and Cornerstone is asking your to validate it. Please be informed that X license code can only be used to validate the X theme. If you only use Cornerstone, you will need a separate Cornerstone license code in order to validate. I went ahead and activated the X theme and have successfully validated the X theme.

Please check your site now.

Aha, ok. I am using x theme so that was what I was trying to do. I didn’t realize there were two separate licenses. Thanks for the help.

You’re welcome. Glad the issue’s resolved.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.