License code doesn't work

Hey there,

My license code doesn’t work at my website I recently changed from themeco to PRO, I don’t know how to fix this and hope you can help me out.

Thanks in advance,

Kind regards,

Ingrid van der Zanden

Hello Ingrid,

Thanks for writing in! ​

To validate X properly, please do the following:
1] Please login to your account and assign the license ( You need to assign the license to your site using this url: You have to make sure that url you just assign is the same as the one you have in your settings, Settings > General > Site Address
2] Go back to X > Overview again, and insert the license code.

And please review the changes that we made on how you are going to validated your X theme because we made a big change in the process. Please check it out here:

Thanks for the fast reply. It still doesnt work. In the past I used this licensecode for another website (, but since I don’t have that website anymore I wanted to use it for Is there anything else I can do?

Hey Ingrid,

​To assist you better with this issue, would you mind providing us the url of your site with login credentials so we can take a closer look? This is to ensure that we can provide you with a tailored answer to your situation.

To do this, you can create a secure note with the following info:
– Link to your site
– WordPress Admin username / password

To know how to create a secure note, please check this out:

Thank you.

Thanks a lot!

Hello Ingrid,

I have logged in to your site and investigated the issue. The validation process did not work because the connection was refused by your server. The console generated this error:

{message: "cURL error 7: Failed to connect to port 443: Connection refused"}

To resolve this, please make sure that connection to is allowed. For more troubleshooting details, please check this out:

Thanks for your reply. I tried all troubleshooting options, but I still can not add my licens. Could it be something else?

Hello Ingrid,

Please contact your hosting provider and ask them to unblock requests to server.
You can use the email sample in the troubleshooting article.

Please let us know how it goes.

Problem solved :slight_smile: My hosting provider unblocked it.

Thanks for all your help, you rock!

You are most welcome. :slight_smile:

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.