JavaScript Error

Cornerstone will not load. I’ve tried using an incognito browser, uninstalling plugins, deleting cache, etc.

One the loading page of Cornerstone this error shows:
Uncaught SyntaxError: missing ) after argument list

I will attach my admin credentials.

Hi Mallorie,

Thanks for reaching out.
It might be due to the improper update of the Cornerstone plugin. I would also suggest you follow the below steps while updating to the latest version of the Cornerstone.

  1. Delete the Cornerstone existing one
  2. After deletion please use the link in the dashboard to automatically install the Cornerstone.

If that does not resolve the issue, I would suggest you troubleshot a few common issues on this.

1.Plugin Conflict
2.Theme Update related issue
3.Child Theme Related issue
4.CSS/JS Customization

If you discover that an issue is coming from a custom code or 3rd party plugin, kindly consult with a developer or contact the plugin author. Please note that we do not provide support for custom codes and 3rd party plugins.
If none of the above helps and you are still getting the issue, please copy your live site to a staging server so we could troubleshoot freely without breaking your live site.
And give us access in the secure note including:

– WordPress Site URL & Login URL
– WordPress Admin username/password

To create a secure note, click the key icon underneath any of your posts.


I deleted Cornerstone and then reinstalled it using the link. It did not work. When I “inspect” the page when trying to load Cornerstone, it shows me the error but I am unsure of how to correct it.

I copied my site over to staging for you.

Hi Mallorie,

Can you please provide login credentials for your staging site in a secure note to examine it further.


Yes it is attached . Thank you!

Hello Mallorie,

I checked your site dashboard. It seems that the Cornerstone page builder is working fine at my end. It might be the issue of browser cache, any browser extension at your end. I would suggest you clear your browser cache and check for a browser extension if you have installed any browser extension on your browser. I am using Google Chrome version 91.0.4472.123. Please have a look at the given screenshot in the secure note.


Cornerstone also loads for me when logged into the staging site. However, when logged into the live site, it does not load. I’ve attached those credentials in the secure note.

Hello Mallorie,

I checked your live site, it seems that there might be an issue with the server cache. I went ahead and compare the JS file(app.2155f74.js) with Diffchecker. It seems that your live server JS file in not rendering properly on your live site as it is rendering on your staging server. I would suggest you, please contact your hosting provider to clear the cache.

Hope it helps

I had Bluehost clear the server cache then logged out and tried to load Cornerstone in a private window through Chrome and am still not getting Cornerstone to load

I just tried to load Cornerstone again and it worked! Thank you for your quick responses and all of your help!!

Hi Mallorie,

We’re glad that you already figure it out! If you have any other concerns or clarifications regarding our theme features, feel free to open up a new thread.

Thank you.

Cornerstone was able to work on my site for a few days, however, is now not working again. I’ve contacted my hosting service to delete the server cache but that did not fix the problem this time- Cornerstone isn’t loading on my staging site either. I am still getting the same Javascript error upon loading Cornerstone. Please help!

Hello Mallorie,

I tried to access your site but the given credentials are not working. Please recheck and send us again.


I’m sorry! They should now be correct in the secure note.

Hello Mallorie,

I am another staff checking in. I have logged in to the live site and I cannot replicate the issue. I can edit any page in Cornerstone without any JS error.

See the secure note.

One thing that I did before editing the page in Cornerstone is clearing the cache.

Kindly use private browsing mode and test your site again.

I followed your instructions and was able to get Cornerstone to work. Thank you!

Hi Mallorie,

Glad that we are able to help you.


This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.