Issue with the preview of portfolio gallery

Hi There.

I used to be able to simply add images to a gallery and the would only show up at the top of the post. (there are little arrows in the top left corner to scroll) Lately, I had the problem that the images would show up at the top but also as a gallery inside the post.
Now I can’t even get them up to the top any more. Only the preview image.

Using the setting media type: gallery and featured content: media does not work.

Any help would be appreciated!

Thank you

Hello Harry,

Thanks for the very detailed post information. I can see that you have inserted a WP Gallery. While you can select which images to display in the WP Gallery, the portfolio’s featured gallery is different. Only the images attached to the portfolio item will be displayed which means that you will have to edit your portfolio item and upload the images while editing the portfolio item to make sure that it is attached to the portfolio item. I would highly recommend that you review our documentation on how the built in galleries works in the theme. Please check it here:

Hope this helps.

Hi. Thanks for your quick answer. Is there a tutorial on what you described in your answer? Because I followed the instructions in the link you sent and it does not make a difference. I click on the “add media” button, select the images, click “create gallery” (in the gallery settings I select “attach to page”) and insert it. Then I scroll down and tick the media and gallery fields.

Do I miss a step?

Thanks again for your help!

Hi @Sue,

To show a gallery, you only need to upload images to the portfolio item. Simply edit your portfolio item and add images one by one at the end of your content using Add Media button:

Now under Portfolio Item Settings make sure you have the following settings:


This will convert your images into a gallery at the top. Let us know how this goes!

Hi. So I added the images at the end of my content (not a gallery this time) and used the following settings

and that is what it looks now:

Hi @Sue,

The settings of Media Type: Gallery and Featured Content: Media should be there as mentioned but meanwhile you need to add the images as a gallery but you need to select the Upload Images mode and not select images.

If you still have problems kindly get back to us with the URL/User/Pass of your website using a Secure Note and we will follow up.

Thank you.

Thank you Christopher. That worked! And what do I have to do to remove the gallery from the text and have the preview images only? Like this post:

Hey @Sue,

I believe it’s the gallery you added previously that you didn’t remove. Please remove it from your content to fix the issue. You can also compare it with the working post e.g here simply edit the “super amart” post and compare the content with your problematic post and make adjustments accordingly.

Hope this helps!

Thank you for your patience and help!

You’re most welcome, Sue.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.