Issue with Gravity Forms

Hello, were’ having an issue where gravity forms is causing memory exhaustion issues on the website. When we go to the page with the form on it, we get a http 500 error:

I’ve reached out to our hosting provide you increase the memory and that hasn’t helped. I’ve also reached out to gravity forms. They noted that there is a theme file error and recommended that I reach out to y’all. The file with the error is: /www/wp-content/themes/pro/cornerstone/includes/classes/components/class-shortcode-finder.php

Please help! Thanks so much.

Hi @ranchhouse,

Thanks for reaching out!

Would you mind sharing your admin credentials so that we can check your backend settings? To do that, please give us the following information in a Secure Note.

  • WordPress Login URL
  • Admin level username and password

You can find the Secure Note button at the bottom of your posts.

Thank you.

Hello @ranchhouse,

Even with the File Manager plugin installed, your WordPress core files are not editable. We cannot modify the config.php file. To better understand what is going on, kindly enable the debug mode. You might be able to see an error message on the site right away. If not, the error log could reveal where the problem is originating. You can do this by opening wp-config.php file and adding

define('WP_DEBUG', true);

/* That's all, stop editing! Happy blogging. */

When you revisit the Careers page, you should have some error output describing the issue in more detail.

Best Regards.

Hello, I have enabled Debug mode through my hosting provider. Maybe it still needs to propagate, but I’m still seeing the 500 error when I got to the careers page. Please let me know the next steps, or better yet, are if you are able to assist further.

Thanks so much for your support!

Hello @ranchhouse,

It might be an issue if corrupted .htaccess file issue of PHP memory limit or any plugin conflict issue. Please have a look at this article to learn more about how to fix the 500 issues.

I would also suggest you troubleshoot a few of the common issues with our troubleshooting guide. Please make sure your PHP memory limit is 512 MB. In case if it is not set as recommended please have a look at our doc to learn more about how to increase the PHP memory limit.

You may contact your hosting provider to update the PHP memory limit.

Hope it helps

@prakash_s As I mentioned in my origianl post, we have reached out to our hosting provider already and increased the memory on the site. We have also talked to Gravity Forms and they indicated seeing an error related to this file: /www/wp-content/themes/pro/cornerstone/includes/classes/components/class-shortcode-finder.php

@ruenel I have enabled he debug mode. Are y’all able to take a look at the issue with the php file issue?

Thanks so much.

Hey @ranchhouse,

if you go to Tools > Site Health, there are some performance issues that need to be addressed like the PHP version and your WordPress core version. Please make to resolve these issues.

In the meantime, kindly increase your PHP memory limit from 256MB to 512MB.

define('WP_MEMORY_LIMIT', '512M');

You may need to ask your host provider again since we do not have any access to your FTP.

Best Regards.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.