Issue with downloading templates: "Service Unavailable"

Hello,

I have an issue on a page where the created template, whether it’s an element, a section, a page, or layout, is being downloaded incorrectly. When opening the .tco file, all files contain the content “Service Unavailable.”

The latest version of WordPress and Pro are installed. The error persists even when all plugins are deactivated.

Thank you

Hi @mrdplusd,

Thanks for reaching out.
There might be a few different reasons for this issue. I would suggest following the troubleshooting steps for your demo import.

  1. Increase PHP Memory Limit
  2. Increase PHP Execution Time Limit
  3. Please check if the mod_security is enabled in your site, which causes the issue in importing and does not let you call the Cornerstone endpoint to import the Design Cloud assets.
    If that is the case, you need to contact your hosting service provider to temporarily disable the ModSecurity for you and make the Cornerstone endpoints whitelisted.
  4. The write permission to the uploads folder might be one of the reasons behind your issue, I would suggest you change the permission to import the images into it.

I also recommend you ask your web host to configure the following server settings with the specified values or more for the PHP.

memory_limit = 512M
upload_max_filesize = 512M
post_max_size = 512M
max_execution_time = 300
max_input_time = 300
max_allowed_packet = 16MB
innodb_log_file_size = 128M
allow_url_fopen = On

And MySQL Configurations

max_allowed_packet = 16MB
innodb_log_file_size = 128MB

If the above does not help, please copy your live site to a staging server so we can troubleshoot freely without breaking your live site.
And give us access to the secure note including:

– WordPress Site URL & Login URL
– WordPress Admin username/password

To create a secure note, click the key icon underneath any of your posts.

Thanks

Hi, I’ve investigated the issue further, but I haven’t gotten anywhere. I have created a staging environment that can be tried out without risk, see secure note.

Hey @mrdplusd,

I was able to replicate the issue on your site. Please increase the following:

upload_max_filesize = 512M
post_max_size = 512M

At the moment, you only have 64M, when you export a template you are also exporting components.

Kindly let us know how it goes.

Hi @ruenel,

Unfortunately, the web host doesn’t let me increase the values to such values. Not even an absolute premium tariff would be enough for this. Unless the customer switches to a private server.

Can you explain why 65 MB is not enough for both parameters? Even if the page template that I want to export contains components, the file size would never be so large that it would amount to several MB, even if images were included.

Specifically, I want to export the archive layout for the blog. That’s it.

I would really like to understand this.

Best regards

Hi @mrdplusd,

The template may not be large but it consists of components and other related resources and that is why size needs to be increased and also execution time needs to be increased. I would suggest you go through the following article to explain how the values can be increased without modifying server settings.

Hope it helps.
Thanks

As I said, I cannot change the values because they are limited by the hosting provider. I tried all possible methods and spoke to two hosting providers. This is shared hosting, not an own web server.

This is a sobering aha moment for me. Because this circumstance means nothing other than that your theme is no longer fully usable for shared hosting once you use components because you cannot meet your required server requirements.

I recommend that you explicitly point out the high technical server requirements in your docs and also in your marketing.

Are you absolutely sure that the problem really only lies with these two values and not somewhere else?

I have this problem too.

  • Memory limit is 1024Mb (exceeds above)
  • Upload is 200Mb (under, but I’m not uploading anything, I’m downloading)
  • Post max size: 512Mb (meets)
  • Execution time: 899 secs (exceeds)
  • Input time: 299 secs (CW warns not to go beyond 300 or more)
  • Allowed packet: Can’t find this in CW
  • InnoDB log: Can’t find this in CW
  • Allow URL: Can’t find this in CW

In my previous downloads of .TCO files the largest I’ve managed to make is 2 megabytes, most of them come in at 2k - 99k, hardly a stretch to download.

Why would the Cornerstone export fail to produce a valid file if we’re not getting anywhere near the limits above?

Here’s the console error messages which sound suspicious:

SecurityError: Blocked attempt to use history.replaceState() to change session history URL from about:srcdoc to https://hardy-plant.org.uk/cornerstone/edit/srcdoc. Protocols, domains, ports, usernames, and passwords must match.

And an http error 500 which is a catchall for server errors - back-end code in Cornerstone causing the issue?

This needs more investigation, it was working before and now it’s broken.

Bill.

Hello, what’s next? Have you taken a closer look at the problem? Do you have a (short-term) solution?

Definitely an issue… tested across multiple sites including sites on my local Ubuntu server that I have full control over.

Hello There,

I have created a TestPage on the site. I added a Section and then saved it as a template. When I exported it and imported it to my local test server, it worked just fine with no issues. It seems that there is something on your Section and other elements on the page that causes the issue. I would suggest that you check out the test page and then import it to your other site to test it.

  • See the URL in the secure note below

Best Regards.

Hello Ruenel,

With standard elements, the creation and export of templates works as it should. As soon as a component is in the template, it no longer works.

Even if it’s a very simple component like a text element, it no longer works.

So we haven’t made any progress so far.

What can we do to finally make progress here?

@ruenel Do you have a status for me?

Hey @mrdplusd,

You are using an older version of the theme. Please update to the Pro 6.4.15 version. Our developers have released a patched update a week ago.

Kindly let us know how it goes.