Is this a cache problem

Hi! I have a page: and as you see the Revolution slider is showing two images on the top of each other. The text I mean. When I am in Rev. slider, I can only see one. So need to be cache. But my system does not let me install WP cache e.g. Any ideas what I could do?

Hi @anni,

Thank you for reaching out to us. This could be due to cache issues, If you’re using a caching plugin, clear all caches including browser cache then deactivate your caching plugin and other optimization plugins. If you’re using a CDN, please clear the CDN’s cache and disable optimization services.

If the issue persists then please test for a plugin conflict. You can do this by deactivating all third party plugins, and seeing if the problem remains. If it’s fixed, you’ll know a plugin caused the problem, and you can narrow down which one by reactivating them one at a time.

Ensure everything is up to date according to our version compatibility list at Please follow the best practices when updating your theme and plugins. See for more details.

If you still have problems then please get back to us with the result of the steps above and URL/User/Pass of your WordPress dashboard using the Secure Note functionality of the post to follow up the case.


Hi! I have done all above and the problem persists. I have emptied the hosting cache, used one plug-in and purce all and browser cache. Nothing works. I give my access on security note.

Now I have the same issue with another page (different hosting). Just with one headline does not show on the right place. It does show on the right place in Cornerstone, but live page not. I have emptied the cache and also tried with other browser. Still the same…The page is and the headline “Käyttämällä järjestelmää saat” should be above the Featured list. Maybe you see it correctly.

Hi anni,

Seems its an issue with Slider Revolution.
In your slider the overlapping image is in Global Layer.
Deleted the overlapping image from Global Layer will work.

We are able to resolve the issue at your end by creating a duplicate slider to test.
Please check the slider Without Overlapping, if everything found Ok please replace the code for slider with below one

[rev_slider alias="without-overlapping"][/rev_slider]


Yes, that was the reason. Your version is working. I still don’t understand how I did that wrong. Are you able to explain how I have done the overlapping? I am not able to find it. Don’t want to do the same mistake again if I am editing the slider. Thank you!

Hi Anni,

Glad it works for you.

There is always a Global Layer present by default in Slider Revolution,
when you add the Slides from Dropdown you can find that.

Image has been added to the Global Layer by mistake, and that’s the cause of error.
I have just deleted the image from it and it works. Its pretty simple.


This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.