Invalid_json - X Theme 8.10

After installing X Theme and Cornerstone on a staging environment I can’t change the Theme Options.

I get an 503 error, “POST 503”:

app.514eb0c.js:42 Failed to save.

1. {code: "invalid_json", message: "Die Antwort ist keine gültige JSON-Antwort."}

  1. code: "invalid_json"
  2. message: "Die Antwort ist keine gültige JSON-Antwort."
  3. __proto__: Object

WordPress status:

### wp-core ###

version: 5.6
site_language: de_DE
user_language: de_DE
permalink: undefined
https_status: true
user_registration: 0
default_comment_status: closed
multisite: false
user_count: 6
dotorg_communication: true

### wp-paths-sizes ###

wordpress_path: /mnt/web302/b1/86/5965086/htdocs/WordPress_05/dev
wordpress_size: loading...
uploads_path: /mnt/web302/b1/86/5965086/htdocs/WordPress_05/dev/wp-content/uploads
uploads_size: loading...
themes_path: /mnt/web302/b1/86/5965086/htdocs/WordPress_05/dev/wp-content/themes
themes_size: loading...
plugins_path: /mnt/web302/b1/86/5965086/htdocs/WordPress_05/dev/wp-content/plugins
plugins_size: loading...
database_size: loading...
total_size: loading...

### wp-dropins (1) ###

advanced-cache.php: true

### wp-active-theme ###

name: X (x)
version: 8.0.10
author: Themeco
parent_theme: none
theme_features: core-block-patterns, cornerstone, post-thumbnails, title-tag, automatic-feed-links, post-formats, woocommerce, wc-product-gallery-zoom, wc-product-gallery-lightbox, wc-product-gallery-slider, align-wide, wp-block-styles, widgets, menus
theme_path: /mnt/web302/b1/86/5965086/htdocs/WordPress_05/dev/wp-content/themes/x

### wp-themes-inactive (3) ###

Twenty Twenty: version: 1.6, author: WordPress-Team
Twenty Twenty-One: version: 1.1, author: WordPress-Team
verticalmenu: version: 1.65, author: the Bill Minozzi

### wp-mu-plugins (1) ###

WP STAGING Optimizer: version: 1.3, author: René Hermenau

### wp-plugins-active (23) ###

Classic Editor: version: 1.6, author: WordPress Contributors
Contact Form 7: version: 5.3.2, author: Takayuki Miyoshi
Cornerstone: version: 5.0.10, author: Themeco
Google Analytics Germanized: version: 1.6.0, author: Pascal Bajorat
Gravitate Event Tracking: author: (undefined), version: 1.5.3
Gravity Forms: version: 2.4.22, author: Gravity Forms
Gravity Forms Event Tracking: version: 2.3.10, author: Ronald Huereca
Health Check & Troubleshooting: version: 1.4.5, author: The community
Hummingbird: version: 2.7.0, author: WPMU DEV
Loco Translate: version: 2.5.0, author: Tim Whitlock
MetaSlider: version: 3.19.1, author: MetaSlider
My Calendar: version: 3.2.12, author: Joseph C Dolson
Open Graph and Twitter Card Tags: version: 3.1.0, author: Webdados
Page Builder by SiteOrigin: version: 2.11.8, author: SiteOrigin
Really Simple CAPTCHA: version: 2.0.2, author: Takayuki Miyoshi
Redirection: version: 4.9.2, author: John Godley
Simple Lightbox: version: 2.8.1, author: Archetyped
Site Kit by Google: version: 1.23.0, author: Google
SiteOrigin Widgets Bundle: version: 1.17.11, author: SiteOrigin
Smush: version: 3.8.2, author: WPMU DEV
UpdraftPlus - Backup/Restore: version: 1.16.43, author: UpdraftPlus.Com, DavidAnderson
WP STAGING PRO: version: 3.1.7, author: WP-STAGING
Yoast Duplicate Post: version: 3.2.6, author: Enrico Battocchi & Team Yoast

### wp-media ###

image_editor: WP_Image_Editor_Imagick
imagick_module_version: 1691
imagemagick_version: ImageMagick 6.9.11-39 Q16 x86_64 2020-12-11
	imagick::RESOURCETYPE_DISK: 9.2233720368548E+18
	imagick::RESOURCETYPE_FILE: 192
	imagick::RESOURCETYPE_MAP: 512 GB
gd_version: bundled (2.1.0 compatible)
ghostscript_version: not available

### wp-server ###

server_architecture: SunOS localhost 5.10 Generic_150401-49 i86pc SunOS localhost 5.10 Generic_150401-49 i86pc SunOS localhost 5.10 Generic_150401-49 i86pc
httpd_software: Apache/2.4.43 (Unix)
php_version: 7.4.13
php_sapi: cgi-fcgi
max_input_variables: 4000
time_limit: 240
memory_limit: 256M
max_input_time: 60
upload_max_size: 64M
php_post_max_size: 76M
curl_version: 7.73.0 OpenSSL/1.0.2u
suhosin: false
imagick_availability: true
	date: Thu, 31 Dec 2020 10:31:33 GMT
	server: Apache/2.4.43 (Unix)
	x-powered-by: PHP/7.4.13
	expires: Wed, 11 Jan 1984 05:00:00 GMT
	cache-control: no-cache, must-revalidate, max-age=0
	link: <>; rel="", <>; rel="alternate"; type="application/json", <>; rel=shortlink
	content-type: text/html; charset=UTF-8

### wp-database ###

extension: mysqli
server_version: 5.6.42-log
client_version: 5.5.54

### wp-constants ###

WP_CONTENT_DIR: /mnt/web302/b1/86/5965086/htdocs/WordPress_05/dev/wp-content
WP_PLUGIN_DIR: /mnt/web302/b1/86/5965086/htdocs/WordPress_05/dev/wp-content/plugins
WP_DEBUG: false
WP_CACHE: false
COMPRESS_CSS: undefined
WP_LOCAL_DEV: undefined

### wp-filesystem ###

wordpress: writable
wp-content: writable
uploads: writable
plugins: writable
themes: writable
mu-plugins: writable

### google-site-kit ###

version: 1.23.0
php_version: 7.4.13
wp_version: 5.6
amp_mode: no
site_status: connected-site
user_status: authenticated
connected_user_count: 1
active_modules: site-verification, search-console, analytics, pagespeed-insights
	openid: ✅ ✅ ✅ ✅ ✅ ✅
	googlesitekit_authenticate: ✅
	googlesitekit_setup: ✅
	googlesitekit_view_posts_insights: ✅
	googlesitekit_view_dashboard: ✅
	googlesitekit_view_module_details: ✅
	googlesitekit_manage_options: ✅
	googlesitekit_publish_posts: ✅
analytics_account_id: 5812••••
analytics_property_id: UA-5812•••••••
analytics_profile_id: 2041•••••
analytics_use_snippet: no


I’ll be adding login credentials in a hidden reply. What can I do?

Hi @XcitingWeb,

Thanks for reaching out.

The reason why the theme options is not accessible because of your permalinks. I change the permalinks to post name and you can now change anything on the theme options.

Hope that helps.

Thank you.

Hey @marc_a ,

please have a look again in @XcitingWeb.

I just changed CSS in Theme options and now its not working again.

Please have a look again…^^ I get the same not valid JSONS anwser and cannot save.

kind regards,


Hello Tarik,

At this moment, we kindly ask that you post your issue in another thread along with your log in details in a secure note so that we can investigate further. In your new thread, please create a secure note with the following info:
– Link to your site
– WP login URL
– WP username
– WP password
– WP Administrator Role

To know how to create a secure note, please check this out: How The Forum Works

Best Regards.


It is the exact same project as mentioned above. @XcitingWeb and me we work on the same project, same, machine, same credentials as mentioned above. So please have a look at the issue above again. We get now the same error code as mentioned in the first post . Only things, that have changed:

  1. Changed CSS in Theme Options
  2. Deactivated 2 plugins

kind regards Tarik

Hey Tarik,

Your site is currently under maintenance.


You can update us once it’s ready.


Hey @christian,

Please try again, its on again

Kind regards,


Hi Tarik,

It might be due to the improper up-gradation of the Cornerstone plugin. I would also suggest you follow the below steps while updating to the latest version of the Cornerstone.

  1. Delete the Cornerstone existing one
  2. After deletion please use the link in the dashboard to automatically install the Cornerstone.

If that does not resolve the issue, I would suggest you troubleshot a few common issues on this.

1.Plugin Conflict
2.Theme Update related issue
3.CSS/JS Customization

If you discover that an issue is coming from a custom code or 3rd party plugin, kindly consult with a developer or contact the plugin author. Please note that we do not provide support for custom codes and 3rd party plugins.
If none of the above helps and you are still getting the issue, please copy your live site to a staging server so we could troubleshoot freely without breaking your live site.
And give us access in the secure note including:

– WordPress Site URL & Login URL
– WordPress Admin username/password

To create a secure note, click the key icon underneath any of your posts.


We’ve deleted Cornerstone and X-Theme 8.10, downloaded the latest tablel release of X-Theme (7.2.3) and reinstalled Cornerstone.

Everything worked fine.

Updated to latest release (X-Theme and Cornerstone) again, same error as before. Will stick to 7.2.3 now, but this is… very annoying.

Hello Tarik,

We will continue to investigate this issue. You can stick to 7.2.3 for now while our developers are investigating.

Please bear with us.

Very well. Any additional information I can provide? We’d like to use loopers. :slight_smile:

Hey Tarik,

To use the loopers, please check out this documentation first:

You may also check out our video series:

Hope this helps.

this doesn’t help, as because of the bug in 8.10 we can’t update from our 7.X version.

My question was: What information can I provide so that you can fix the bug in your 8.X version that causes the invalid JSON reply?

It’s been 19 days. :slight_smile:

Hi @XcitingWeb,

I would suggest you copy your live site to a staging server and update the theme into the latest version i.e 8.0.11.
And give us access in the secure note for further investigation, including:

– WordPress Site URL & Login URL
– WordPress Admin username/password

To create a secure note, click the key icon underneath any of your posts.


Hi Tarik,

By withdrawing the post, I believe you already have resolved the issue. If the issue still existed, you can let us know.


This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.