Inspector not working after update

I am using the X theme, I updated to the latest cornerstone version 6.1.4 and when I click in any element in a page, the inspector appears “thinking” (circular progress bar) but it never shows the content of the section I clicked. So it is impossible for me to edit anything. Help.

Hi @abrena,

Thanks for reaching out!

There could be a plugin or custom code that affects the inspector.

I recommend the following troubleshooting procedures before we investigate the settings.


Only if none of that helps, please give us the following information in a Secure Note.

  • WordPress Login URL
  • Admin level username and password

You can find the Secure Note button at the bottom of your posts.

Hope that helps and let us know how it goes.

Hi there, I tried this solutions and I still see the issue. I will send you a secure note with the information you requested

Hello @abrena,

I tried to access your site but the given login details are not working, please recheck and send us again.


Hi There,

Thanks so much for checking this out, there was a problem in the password, now is corrected in the original secure note.

Hello @abrena,

It appears that though you have updated the X theme to version 9.1.4, you have forgotten to update the Cornerstone plugin. Please make sure that you are up to date. Our latest updated/supported version are:

  • X theme 9.1.4
  • Cornerstone 6.1.4
  • WP core 5.9
  • PHP 7.4

You can check out the compatibility issues here:

After the updates, you may need to clear all our caches before testing your site. If an issue exists after the updates, please check this out:

Kindly let us know how it goes.

I updated the versions to the ones you mentioned and it worked!

Thank you!

Hi @abrena,

You’re welcome and it’s our pleasure to help you! If you have any other concerns or clarifications regarding our theme features, feel free to open up a new thread.

Thank you.

Hi @marc_a,
I have a similar problem. Whenever I want to edit a page, the functions in the inspector are not loaded and a loading icon is always displayed.
I have read this blog and did everything that was described here. However, without success. Unfortunately, the inspector still does not work. What else could be the reason for this?
Thank you very much.

Hello @Christian_2015,

I would suggest you please open a new thread and share your details so that we can check your setting. It would be best you if you could troubleshoot a few common issues before we check your settings if it doesn’t work, copy your live website to your staging area.]( and send your details in a secure note so that we can investigate your setting without breaking your live site.


This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.