Impossible to upload template (it's NOT a max. upload size problem)


Impossible to download template after website migration.
I get the message “your file is not properly formatted”. It’s a “.tco” I downloaded a few days ago before the transfer.

I searched the forum & often it’s a max. upload size problem. but not here!
I can upload up to 512Mb on my wordpress and the template is less than 10mb…

Please help.


Hello Stéphane,

Thanks for writing to us

In order to help you with your concern, we need to check your settings. I would request you please share your details in a secure note. Please provide the following details

  • WordPress Login URL
  • Admin level username and password

You can find the Secure Note button at the bottom of your posts


Hi Stephane,

I was able to upload a .tco file on your site

Maybe the issue is on your .tco file? Can you share to us your .tco file?

Also, I notice a lot of things on your site is outdated (WordPress, Theme, Plugins) can you update your site? We cant provide support if the issue is cause by incompatibility because of outdated version.


Hi Friech,

Thanks for your response.
I updated all my plugins & themes but the upload still not work.
Here is the .tco =>

Thanks a lot!

Hi Stephane,

I have downloaded and imported the shared .tco file in my local environment and it worked. It also shows the Template while trying to Load Template into any page. I have also tried to upload the same .tco file in your server, but it just imported only a few image files not full template.

There might be some different reasons behind your problem, I would like to suggest troubleshoot the following common issue to help us to recognize the reason.

1.Theme Related Issue
2.Plugin Conflict
3.Theme Update related issue
4.Child Theme Related issue
5.CSS/JS Customization
6.Disabling Cache
7.Disabling CDN
8.Increasing PHP Memory Limit

If you discover that an issue is coming from a custom code or 3rd party plugin, kindly consult with a developer or contact the plugin author. Please note that we do not provide support for custom codes and 3rd party plugins.
If none of the above helps and you are still getting the issue, please copy your live site to a staging server so we could troubleshoot freely without breaking your live site.
And give us access in the secure note including:

– WordPress Site URL & Login URL
– WordPress Admin username/password

To create a secure note, click the key icon underneath any of your posts.


Hello Tristup,

Thanks a lot for your response.
I just answered in the secure note above.



Hi Stéphane,

The credentials are for the live site, so as I have suggested in my previous comment please copy your live site to a staging server and give us the credentials for that to troubleshoot freely without breaking your live site.


Hi Tristup,

You’re right. I just installed the staging site.
As you may know it’s within my wordpress.
Thanks a lot.


Hello Stéphane,

It seems that the Cornerstone Endpoint is not whitelisted yet, and that is why the error still exists. Please find the URL in the secure note, which needs to be whitelisted.

I would suggest you contact your hosting service provider to temporarily disable the ModSecurity for you and make the Cornerstone endpoints whitelisted.

Hope that will resolve your issue.

Hello Prakash,

The endpoint has been whitelisted but now they say the problem is on your end…

Hi Stéphane,

I would suggest you ask your Hosting Service provider to disable the ModSecurity for temporarily to check if that is the reason behind your issue. Unfortunately, I am not able to access your Staging server to test the whitelisted endpoints.


Hey Tristup,

I contacted them and they answered this about disabling Modsecurity:

Upon reviewing the escalation notes, I understand that you are receiving the mod security error at the link:
However, when I access the same link, I could notice the message as " {“success”:false,“data”:{“invalid_user”:true,“message”:“nonce verification failed.”}}"
Here is the screenshot that I can see from my end when I accessed it:
Further, I have checked server logs and your local IP and found ModSecurity rules generated for the cornerstone and whitelisted triggered nod_secuiry rules and your local IP.

A heads up that mod_security is an apache module that helps to protect your website from various attacks. It is used to block commonly known exploits by use of regular expressions and rule sets and is enabled on our shared servers. Mod_security can potentially block common code injection attacks which strengthens the security of your account as well as the server. That is the reason why mod_security plays an important role and sometimes the rule blocks become necessary as a safety measure.
Unfortunately, it is not possible to disable the Mod_secuirty on our server for security purposes, and I really do apologize for any inconvenience.

It is advisable to clear browser cache and cookies or try connecting to different network providers (Wi-Fi, routers). Here’s a link to learn more about clearing the browser cache:

Please confirm the functionality on your end and if the issue persists please reply to this email with the following information to troubleshoot further:

  1. Exact steps to replicate the issue on our end.
  2. Exact URL where you experience the issue with the screenshot of the error.
  3. What should be the output or content of the above link while accessing.
  4. Provide us with the local IP of the device. Here is the link to get the local IP of the device:
  5. Also, get back to us with traceroute information of the website, here is the help link to get it:

Anyway, I still don’t get it… I can upload 2 of the 4 templates now… why the last 2 are still blocking???

Those 2 are the one I can’t upload:

Could you try to upload them on your end again please?

Thanks a lot,

Hey Stéphane,

I was able to download and update the templates in your template manager.

Please check your site again.

@ruenel thank you so much!
Thanks a lot to @tristup, @prakash_s & @friech!
You rock guys!!!
Great customer support, awesome team!
Thanks a million!

You are most welcome Stéphane.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.