Image high res in pro builder but not onces publsihed

Hi Guys,

The image on my custom 404 page is high res and super clear in the pro builder but then when I test in Chrome it looks blurry.

Any ideas?

Hello Niall,

Thanks for writing in! You are having this issue because of the Site Accelerator feature that was enabled in the Jetpack plugin. The Site Accelerator will cache all your images and sometimes it has some problems loading the images. One of the limitations of photons:

  • No cache invalidations – currently the images are cached “forever”.
  • If you want to “refresh” an image you will need to change the name of the image.
  • Adding random query arguments, commonly known as cache busters, will not work.

You can check it here: https://jetpack.com/support/site-accelerator/ for further information.

For the time being, please disable the Site Accelerator module and test your site again. You will find that the full images will be displayed without a hitch.

Hi @ruenel

What does this mean? I can see that this is the case. Having disabled it the image loads perfectly.

But what do I do next? Surely this isn’t a fix if I want my site to run faster?

Hey Niall,

Just to clarify, this is a problem with Jetpack’s module and not our theme so there is nothing to fix on our end.

Image optimization in WordPress is not done by themes. There are many ways to optimize images from manual methods to fully automatic like shown in this user video: https://youtu.be/M4GCDahSTnE

You can also learn from our Image Optimization guide in our Performance article here: https://theme.co/docs/how-to-improve-site-performance#image-compression

We also have a performance video series on our Youtube Channel. I’d recommend you check them out.

Hope that helps.