Icons still missing on updated X Theme with Integrity Business

Just installed your X Theme and Integrity Business on a new WordPress 5.5 site and noticed that many of the icons on the Home page are missing like Search in the main nav menu and other icons throughout the page. Checking in the Forum, you stated many times that simply updating the themes should solve the issue. I did that, but it hasn’t worked. Clearing the cache made no difference either. What else can be done to make the icons display correctly? Please explain.

Also, I wanted to remove the search option from the main nav, but it appears that the answers in the forum are antiquated as they tell me to go to Appearance > Customize > Header > Search. However, no such option for “Header” exists on my screen while in Customize. Does this need to be done somewhere inside the X > Theme Options instead? Please confirm this as well.

Hi Shane,

Thanks for reaching out.

You can try our troubleshooting docs on how to fix font-awesome icons issue. https://theme.co/docs/font-awesome-icon-issues

To remove your the search bar in the navigation menu you need to go to X > Theme Options > Header and turn off the Navbar Search Option.

Hope that helps and let us know how it goes.

Thank you.

Thanks for pointing out where to turn off the navbar search function. Much appreciated.

As for the x icons, I can see them clearly when I am in Theme Options. They all appear just fine. However, as soon as I save and leave Theme Options to view the live page, the icons are missing. How can they be visible within Theme Options, but gone on the live page? Is not the page still hosted on the same server (Apache or otherwise) while I am editing the site? I certainly would think so, so why are the icons visible when editing, but not visible when viewing? This makes no sense to me.

Hello Shane,

I have checked your license code and it seems that your site is under construction mode. To better assist you with your issue, kindly provide us access to your site so that we can check your settings. Please create a secure note with the following info:
– Link to your site
– WP login URL
– WP username
– WP password
– WP Administrator Role

To know how to create a secure note, please check this out: How The Forum Works


Icons show up just fine when in Cornerstone editing.

But as soon as I go to live preview of the page, they disappear. See where the social media icons above should be.

Also, the icons appear fine when in Theme Options, too. They seem to be missing only in the live preview of any pages.

Hello @SMCFreelance

I tried to access your website Dashboard by your given login details but unfortunately, it is not working please check the credentials and send us again


Resent the login info above. BTW, today, not only were the social media icons not showing in preview, but neither was the Back to Top icon, nor the arrow icons next to “About”, “Contact”, etc. I turned off the breadcrumbs and the nav search function, so even though those icons were missing as well, they are not an issue now. However, other icons inside pages, like About, are missing, too, in preview. Thanks.

Hey Shane,

Thank you for the credentials. I checked your site and Icons are displaying fine in live preview and even after disabling the coming soon page. I tested your About Us page in multiple browsers and all icons are displaying on my end (see screenshots)



I also checked for any errors but there are no errors either. Try clearing all caches including your browser’s cache and see if this resolves the issue. If the issue persists then please share the OS and browser information where you’re checking your site so we can try to replicate the issue.


So…you are telling me that you did absolutely nothing?

Hmm. -_-

When I logged in this morning, and went to preview, the icons were all working correctly. Therefore, I assumed that you did SOMETHING to make them now appear. However, you are saying that all you did was turn off (and then apparently back on) the Coming Soon screen.

If true, then I guess somehow you got lucky and that plugin was causing the error, but suddenly now isn’t, since the Coming Soon mode is active again.

Well, thanks for checking. Apparently, you nailed it without even trying. Much appreciated.

Hi Shane,

You are most welcome. And we are glad that it resolved.


Logged back in today. Icons are now missing again when in WP preview. I can see them fine again in Theme Options only. Not sure what is going on, but I guess there never really was a fix.

Hi Shane,

I just check your website in WP preview and also incognito mode while disabling the under construction plugin for the meantime to check the website and the icons are just working fine. I strongly advise that you clear your browser cache.

Hope that helps.

Thank you.

That makes zero sense. If the issue was my browser cache, how the heck can I literally go back and forth between the Cornerstone preview and the WordPress preview repeatedly in the same tab, and see the icons clearly in one and not in the other. If the icons are in my cache, they should be appearing on BOTH, not always in Cornerstone, but never in WordPress. FYI. per my settings, the browser cache clears every time I close it, so I know that isn’t the issue. Thanks anyway.

Hey Shane,

Though my colleagues have seen the icons, I am having a different result on my screen. All I see are squares in places where icons where suppose to be. I have investigated it already and I found out that you are having a CORS (Cross-Origin Resource Sharing) issue. To get this resolve, kindly check and follow the suggestions from this documentation article:

Kindly let us know how it goes.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.