Icons in PRO not displaying/Option to edit posts in PRO no longer available?

Hi there, I posted a few weeks ago regarding the icons in pro not displaying, and I followed your advice which seemed to work, but now the icons are missing again. Any idea why this might be?

Also, I want to be able to turn on posts so that I can edit them in pro, but that option doesn’t seem to be available now?

I have about 20 WordPress installs, all hosted on siteground, all using Pro, and this is the only one I have issues with. Help.

The site is oceanbottega.ca

Hi Ken,

Thank you for reaching out to us, Since you’re using SiteGround, could you please clear your site cache or temporarily disable the Supercacher in your hosting panel? The SuperCacher is developed by SiteGround exclusively for their customers. It increases the number of hits a site can handle and boosts the website loading speed. The SuperCacher includes 4 different caching options for maximum optimization of your websites. You can access the tool by clicking on the SuperCacher icon in your cPanel.

For more information about this, please check it out here: https://www.siteground.com/tutorials/supercacher/supercacher_intro.htm

If the issue persists then we’ve found that clean installation of WordPress and turning off the HTTPS Enforce within SiteGround fixes the issue.

To enable content builder to edit posts, please follow https://theme.co/apex/forum/t/cornerstone-in-post/49839/2

Let us know how this goes!

Thanks!, I think that worked, but it still doesn’t explain why it happened in this instance and none of the other exact same configurations… Also, Is this just a work around? I’ll need to turn the super cacher back on, and the https enforce, will that cause the same issue again?

Hey Ken,

The suggestion to disable caching whether by using a plugin or a built-in feature by the web host is just to test if it’s the cause of the issue. The use of caching is recommended in general and in fact, it’s mentioned in our performance guide. See https://theme.co/apex/forum/t/customizations-performance/210

Because there are different caching systems though, we can’t take everything into account and we do not know what other features a caching system includes. With that said, we can’t really explain why the Pro icons disappear when you enable your host’s caching system. What we can tell is Pro interface icons are made with SVG. It is the web host who can explain why SVGs could not be displayed in their particular system.

Since you said your other sites are working using the same caching system, there could be something unique in your particular site (oceanbottega.ca) that is causing issue in the first. It could be another third-party plugin, difference in WordPress setup, etc… You will need to compare everything in your working site and the site with issue.

We are not sure if enabling Super Cacher and HTTPS Enforce will cause issues again. You will need to try activating theme and monitor if the issue will come back.

If it does, please first try purging all caches in Super Cacher and also clear your browser’s cache and also test in incognito mode and other browsers.

I’m not sure how HTTPS Enforce will affect the icons since it’s only a redirect of HTTP to HTTPS. It could be that the problem is with your WordPress setup. We will need to know first what really is causing the issue.


Hey thanks for the info, I’m really not sure what’s going on. I’ve already checked for plugin conflicts, the https enforce, and the super cacher, and I can’t get it to work. I’ve even deleted and replaced the wordpress installation, reinstalled the theme & child theme… There is literally no difference between what I’m doing now vs every other site. I can’t explain it…

Hello Ken,

Would you mind providing us access to your site so that we can check your settings? Please create a secure note with the following info:
– Link to your site
– WordPress Admin username / password

To know how to create a secure note, please check this out: https://theme.co/apex/forum/t/how-to-get-support/288


This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.