Icons in cornerstone editor disappeared after update

Hello Valentina,

Thanks for writing in! Missing icons are very common, and it’s usually due to cache, or icon files are deleted, or blocked and it’s something any theme could do especially it’s dependent to those files.

In your case, the SVG files aren’t loading or not readable. Though, I can say the SVG file exist and accessible, it’s just that the builder is unable to process it. And since SVG are vector data, it could be affected by other features or encoding that will render it corrupted. As of now, I can’t fully find the details from the admin but this could be hosting related.

If you are hosted in SiteGround, you can turned off HTTPS Enforce within SiteGround panel. There might be a relation to this HTTPS setting in your case if you are using a different host. Please refer to this thread

Hope this helps.

Hi, thank you, but if I’ve understood what it says, I have to disable the https setting.
Isn’t there anything else to do instead? I need https to be enabled!

Could be useful to provide to you login credential?

Hi Valentina,

Turning the HTTPS Enforce off doesn’t mean disabling https. Your site will still be in https but it will allow the theme to look for the icons using http. Can you try disabling it and test if the issue is still there? If the issue still there, please provide as with a login credential in a secure note. Thanks!

I’ve checked with the hosting, they say we have a proxy that only goes with https, it’s nginx and that they can’t use both http and https…

Hey Valentina,

This is an issue with your HTTPS setup. I see that your WordPress and Site URLs are still in http. Those should be in https. That will still not solve the issue though. Please contact your web host to redirect all resources to https.

Every asset that we load is using the plugin_dir_url so if your SSL setup is correct and if your server does not have anything overriding the protocol, the icons would be displayed.


Hi Christian

Indeed we have an overriding protocol.
The website is in http and the reverse proxy is https.

What can we do?

Hello Valentina,

Please edit your .htaccess in your WP installation folder and add this lines:

# BEGIN rlrssslReallySimpleSSL rsssl_version[3.2.5]
<IfModule mod_rewrite.c>
RewriteEngine on
RewriteCond %{HTTP:X-Forwarded-Proto} !https
RewriteRule ^(.*)$ https://%{HTTP_HOST}/$1 [R=301,L]
# END rlrssslReallySimpleSSL

This should make sure that everything will be using https protocol.

Please let us know how it goes.

Hello! I’ve tried but i’m sorry to say it doesn’t work…

Hi Valentina,

At this point, we might need to you to consult the server provider to check your setup and fixed this for you.
The error is browser level, the URL must be https upon browser request and not after. That would need URL replacement and wp-config URL configuration to fix it. So yes, redirection is not enough since internally, Wordpress still uses http.

Hope this helps.

Hi Lely, i’ve checked in the backend and the website in general settings points to https:// in both Wordpress and Website URL, while in the screenshot the staff posted it seems http… does it change anything?

The hosting only uses reverse proxy, it has always worked since the last update of the theme…

Hello Valentina,

Can you please disable the reverse proxy and we can check if the icons display again?
We need to back to the last setting that it has work in your site.

Please let us know how it goes.


I’ve checked with the support and they say they can’t disable the reverse proxy…but! if you check in the page they say you can see there are both https and http calls, and the http don’t pass through it. Does it helps?

Hi Valentina,

The fact that these resources (svg files) are requested via http, that means your http to https migration has failed.

Try all the methods provided here.

If the issue persists, please provide us FTP credentials in a secure note so we can take a closer look.


We have tried all of them but it doesn’t work…

Hi Valentina,

I tried to access the ftp but failed. Can you double check? Thanks.

Also, have you tried updating your wp-config’s WP_SITEURL & WP_HOME ? If not, try putting https there.

    define( 'WP_SITEURL',  'https://' . $_SERVER['HTTP_HOST'] );
    define( 'WP_HOME',    'https://' . $_SERVER['HTTP_HOST'] );

Hope it works.

Hello, I’ve tried and it works, maybe it’s for the host number, I’ll write it in secure note!

Hello Valentina,

Unfortunately, FTP is not working still.I have tried it, and then ask another support. Both of us cannot connect.

We also tried better search replace plugin to search internal URLs because Cornerstone cache is save in the Database but the search is not really working.

At this point, we need you to setup a separate staging site where we can disable everything. Then send us complete wordpress and FTP credentials inside a secure note.

Ok, I’ve checked with the host, they opened the FTP 'till Friday

Hello Valentina,

Thanks for updating the thread.

FTP credentials is working fine. I logged into the FTP and I tried to make the changes in wp-config.php file but that’s not helping to resolve the issue. I also don’t see .htaccess file on the server even though the permalinks settings changes are taking effect.

In that regards, I suggest you to create a staging server on a different hosting environment and then share the login details and FTP credentials for us to take a closer look.


This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.