Icons gone with last update X 7.1

Today I updated to X 7.1 and all icons were gone from my site. As suggested somewhere on the support portal I downgraded tot 6.5.6 stable release and most of them back, but I cannot add icons with headers etc. Error message:
No Icons Available
You currently have all Font Awesome familes disabled (I did not know I did as it worked before …)

Strangely I cannot even add a graphic to a subheader text instead of an icon too. I can add it but it doesn’t show on the site.

Hi, I have the same issue here. I’ve upgraded from 6.5.6 to 7.10 and lost icons from the menu on our dev site. Luckily I didn’t do live without testing first. I Googled around and found this:

but it made no difference
Any idea when this might be fixed please?

Hi @Meerman,

I’m sorry to hear you’re running into this. Would you mind sharing login credentials so I can take a closer look? You can add a secure note.

@KevinByass, I can take a look at your site as well, but it would be best if you open your own topic before providing login info so it is only seen by our staff. Thanks!

Thanks I have created a new topic with a similar title.

:thumbsup: Thanks! I just replied over there as well.

I’ve the same problem.
When I update I lose many icons.
Is there a solution unless downgrade?

Hi @marco.giuliani,

If you open a separate thread we can check your site as well.

Hi again,

I’ve been looking into this and I believe I have a fix, but have yet to confirm with anyone who has reported the issue if it is the same problem. If anyone is willing to let me install a patched version of Cornerstone let me know. In addition to possibly getting your site back in order quickly, this would help us expedite getting the release out as we can be confident the changes address the reported problem. For now we will keep doing some testing, and once we’ve confirmed this fixes the reported issue we will push out a point release.

Just remember to only post login credentials on threads created yourself. Thanks everyone!

Update: We’ve pushed an update including a fix for an issue with Font Awesome icons. I wasn’t able to confirm if this is the same issue mentioned here, but I would advise updating to see if your issue is resolved.

Solved for me! Thank you!

You are most welcome!

Had the same issue, but cornerstone update fixed it. Thanks.

Icons gone after update to 7.1.1, and could not login to WP admin panel. Also, WP sent me a message saying there is an error with X theme.

Reverted X to v 7.0.4 (only available stable version I found). After was able to get into admin panel of WP, but icons still missing.

However, when logged in as admin and view site, the icons are displayed, logout and the icons disappear.

When I try to edit the element using the icon, I get the message that Font Awesome is deactivated.
I could not find any control in Theme options to activate it, the notes found on this forum have not worked.

So now what?

Any suggestions would be helpful


PS found that the icons do display on mobile device, but not on desktop.

Hi Ray,

I’m sorry you’re having issues after updating. Did you happen to catch the exact error message? Knowing that would help us get a better idea of what is going on. If the icons are displaying on mobile and not desktop, it sounds suspiciously like something is stuck in a cache somewhere.

You can try fully deleting X and Cornerstone, then installing again from the latest version. After updating, clear any caches being used (plugins, browser, and anything in your hosting account)

If you’re still having trouble, feel free to open your own thread and include a link to your site. We can take a closer look there at what is happening.

Hi Alexander,

I don’t feel very confident with the comment “You can try fullyy deleting …” - what if this doesn’t resolve the issues that popped up with the normal upgrade to 7.1.1 and possibly makes things worse?


Hey Martin,

Please create a staging copy of your website so you could test the update without the risk of breaking your live site. You can learn that in this third-party article: https://www.wpbeginner.com/wp-tutorials/how-to-create-staging-environment-for-a-wordpress-site/

In case you don’t want that, I’d recommend that before deleting X and Cornerstone, install and activate our Under Construction plugin so that your website users will be notified that you’re site’s under maintenance while you continue setting up the update and if there are new issues. We couldn’t say if there will be new issues by the way because it is impossible to take into account all of WordPress user setup. What our core developer said is it fixed the issue for him.

Personally, I experienced this issue in my test site and even I have not updated to the latest version. What solved the issue for me is I made sure ALL Font Awesome Families are enabled in Theme Options > Miscellaneous and then I cleared all caches of my caching plugin and then I logged out and then cleared my browser cache. That’s a bit of an overkill but that ensures all caches are deleted.

Hope that helps.

Strangely enough I don’t see those Font Aw options under X>Options>Misc

Hey Martin,

I’m sorry I should have added that I have already upgraded to Pro 3.1.0, X 7.1.0, Cornerstone 4.1.0 that is why I have the Theme Options > Miscellaneous option.

What I meant by:

is that the issue happened to me using Pro 3.1.0 and that’s when I cleared all caches like what I said:

Please update to the latest version and if the icons don’t show up still, apply the same thing that I did to my site.


This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.