Icons are not appearing anywhere on website

Hello! The issue I’m having is that, basically, the icons are not appearing anywhere on my website. They had been at first, and then stopped. I’m not sure what caused that to happen, whether there was an update, etc. Unfortunately, this has been happening for quite some time and I’m not sure exactly when it started, so it’s difficult for me to trace back and try to figure out what may have caused it.

As per some of the other threads, I tried clearing cache as well as checking the code to ensure the “x-” is appearing. However, neither of those affected this issue. Is there something else I can look into?

Please note that, while I’ve been using WordPress for a while, I’m still a beginner with coding, so it is possible that I may not have understood some of the solutions that were suggested in other threads. Thank you for your help in advance.

Hi @uniquevideocreations,

Thanks for writing in! I have inspected the site that is associated with your license. It seems that you are using an older version of the theme and Cornerstone plugin. Could you please update to the latest versions?
Our latest versions are:
- X theme 6.5.5
- Cornerstone 3.5.4

This latest release contains fixes for several issues so be sure to check out the changelog (http://theme.co/changelog/).

_After doing the updates, always remember to clear all caches (if you are using WP Rocket, WP SuperCache or W3 Total Cache) when updating so that the code from the latest release is always in use. This will help you to avoid any potential errors.-

Please let us know how it goes.

Thank you for your response, @RueNel!

In order for me to try this, it appears I need to do another thing first. We recently migrated our website from WordPress.com to Bluehost. Since moving to Bluehost, it says in the dashboard that “x” needs to be validated. I enter in the license code and, upon hitting enter, the page simply goes blank. Do you know of any issues with validating x on Bluehost…? In order for me to update, I’ll need to do this first.

Thanks, again, for your help!

Hello @uniquevideocreations

Thanks for updating the thread. :slight_smile:

I suggest you to manually update the Theme by downloading the package from link shared below. Once you have manually updated the theme, please proceed to validate the Theme. Along with that I suggest you to update WordPress to version 5.1.1 if you are using old version.

Kindly scroll down to manual update section on instructions to manually update:


Thank you, also, @Prasant! So, I tried to do this, but no luck. I talked with Bluehost tech support and they said that the theme update must be breaking the website, and that we should ask the theme developers to help with this.

The WordPress version is 5.1.1. It’s just the theme that’s outdated. And, when I try to update the theme on WordPress (on Bluehost), there is an error message stating that the installation has failed because the target folder already exists. I attempted to remove the target folder, and then install again, but it stated the same thing.

Could you please let me know how I could resolve this? Thank you, once again.

Hello @uniquevideocreations,

Thanks for updating the thread.

If you haven’t made any changes into parent theme files then please do following:

  • Login using Filezilla and under /wp-content/themes/ folder, either rename or delete X Theme.
  • After that download latest version of X Theme and under Appearance > Themes > Add New select the file and install the same.

You also have the option to uploading the file using FTP software like Filezilla:

  • Unzip x.zip on your computer.
  • Rename the x folder to x-updating.
  • Connect to your server via FTP and navigate to your /wp-content/themes/ directory.
  • Drag and drop the x-updating folder into your themes directory.
  • Upon completion, rename the previous x folder to x-previous.
  • Rename x-updating to x. Your site will now be at the latest version.
  • Delete the x-previous folder.
  • Visit the WordPress dashboard at least once to ensure any migration logic can run (this happens behind the scenes).

To get started with FTP and Filezilla, please take a look at following resource.

Once you are done with updating, proceed to validate the website.


Thank you so much, @Prasant! So that^ really helped, and the icons are now appearing! I am having one more issue still, unfortunately.

I’d like to ensure that the x theme is validated on my new website on Bluehost. I followed the process provided here to assign to the new domain (uvc.tv), away from the old domain (uniquevideocreations.tv). However, the dashboard for uvc.tv still states that the theme is not yet validated.

So, I went back to WordPress.com and logged in to uniquevideocreations.tv to see if there is any way for me to unassign the theme over there, but I couldn’t find a way. By the way, just so you know in case this helps, I’m in the process of moving the website away from uniquevideocreations.tv (WordPress.com) and over to uvc.tv (Bluehost). So the uniquevideocreations.tv will be closed in a few days, and I will only be using the theme in one place, uvc.tv.

Additionally, again in case this info helps, I noticed that the website URL on Bluehost had been set as “https://www.uvc.tv” and I changed it to “https://uvc.tv” - and I made sure to reflect this URL change in the Themeco licenses settings as well. Just letting you know in case this may be causing any issues by any chance (I’m not sure if this matters, but I only did this because I want to make sure visitors are able to get to our site regardless of whether they type in the “www” part.).

Thank you so much, again, for your help! You’re a rockstar.

EDIT: My apologies, @Prasant! I actually just tried it again and it worked! The theme appears to be validated on uvc.tv now, so I can close down uniquevideocreations.tv with peace :slight_smile: Thank you, sir, for all your help!

Glad to hear that site is now validated. :slight_smile:

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.