I have no theme editor in my WordPress

I can’t find the theme editor in its usual place of Appearance - Theme Editor. Why is this?

Hello Minna,

Thanks for writing to us.

I tried to access your site but the given credentials are not working. Please recheck and send us again. I would suggest you use the FTP and at the root directory of your WordPress. Open up your wp-config.php file, and search for

define('DISALLOW_FILE_EDIT', true);

Change true to false:

define('DISALLOW_FILE_EDIT', false);

You can also try this tricky solution as well. You can access the theme editor by using URL


If it doesn’t work for you I would suggest you troubleshoot with a few of the common issues before we investigate your settings.

  1. Testing for Plugin Conflict
  2. CSS/JS Customization
  3. Version Compatibility
  4. Disabling Cache

If it doesn’t work for you, please share your details in a secure note. Please provide the following details

  • WordPress Login URL
  • Admin level username and password

You can find the Secure Note button at the bottom of your posts


I changed the password so you should be able to login now.

Hi Minna,

I have checked your site and found that the define('DISALLOW_FILE_EDIT', true); is written into your wp-config.php file. I went ahead and comment out the code and now the Theme Editor can be seen under the Appearance menu.



thank you so much! Have a great day.

Hi Minna,

You are most welcome.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.