How to fix ? (Parameter must be an array or an object that implements Countable in)


How to fix it ?

Thank you

Hi @EDIT_workshop,

Thank you for reaching out to us! You are seeing PHP warning messages that may have came from either a third party plugin or you may have not updated the theme, plugins, WordPress or PHP version.

You can test for the following first:

  1. Ensure everything is up to date according to our version compatibility list at Please follow the best practices when updating your theme and plugins. See for more details.

  2. If you’re using a caching plugin, clear all caches including browser cache then deactivate your caching plugin and other optimization plugins. If you’re using a CDN, please clear the CDN’s cache and disable optimization services.

  3. Test for a plugin conflict. You can do this by deactivating all third party plugins, and seeing if the problem remains. If it’s fixed, you’ll know a plugin caused the problem, and you can narrow down which one by reactivating them one at a time.

  4. If you’re using child theme then and switch to parent theme.

Alternatively you can get rid of this message by turning off the debug mode. You can do this by opening wp-config.php and adding:

define('WP_DEBUG', false);

When you revisit the page, you should no longer be seeing the message.

Hope this helps!

I have updated everything that can be updated, but this sentence still appears.

I just want to add the store function to my webpage. Can you just have the store function in your theme?

Thank you

Hi @EDIT_workshop,

Would you please kindly get back to us with the URL/User/Pass of your website using a Secure Note and also the URL of the page that you see the message?

I also, wonder what happened when you changed the theme from X to another theme? If the problem persists that means the issue is not related to our theme.

To be able to add a storefront to your website you need to use the Woocommerce plugin. Please kindly read this article for more information.

Thank you.

I just basic on wedding theme to design my website, I just want to add the shop function in there . I also installed woocommerce , but the page of shop haven’t design . How to get your shop theme in my website.

Hot to get Full WooCommerce Integration + 4 Unique Shop Designs ?

Thank you

Hello @EDIT_workshop,

Please be advised that we have released X 7.2.2 and Cornerstone 4.2.2. It is now available in automatic updates. You can now update to this latest version. This latest release contains fixes for several issues so be sure to check out the changelog (

After doing the updates, always remember to clear all caches (if you are using WP Rocket, WP SuperCache or W3 Total Cache) when updating so that the code from the latest release is always in use. This will help you to avoid any potential errors.

And then go to X > Theme Options > Icon > Shop Options and then in X > Theme Options > WooCommerce > Shop, you must select the number of Columns.

We would love to know if this has worked for you. Thank you.

I follow to go to theme Option > woocommerce >shop to set the columns but my shop haven’t changed.

Hello @EDIT_workshop,

If that is the case, please provide us access to your site so that we can check your settings and investigate further. Please create a secure note with the following info:
– Link to your site
– WordPress Admin username / password

To know how to create a secure note, please check this out:

Meanwhile, please update to the latest version X theme 7.2.2 and Cornerstone 4.2.2 too.



I will let you know and I can’t find any portfolio page , please help me to check

Thank you

Hello @EDIT_workshop,

We can’t log in. We encounter this.
Please double check.


Please try again.and ten of pages ( Chinese name)use edit with WPBakery Page Builder to perview the page all is night , but check it back something will missing and wrong . could you help me?

Thank you

Problem has been solved


Glad to hear that, @EDIT_workshop. Have a great day!

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.