How To Add Filter To Portfolio Grid (ESS)


We have added a new Portfolio Category to my website but we can’t get it to show on the Portfolio, which uses an ESS Grid I believe -

Can you please explain how we can add more filters buttons to our portfolio?

Hi @durhamld,

Thanks for posting in.

It should be in your EG’s filter-sort configuration but as long as you selected the category in your source settings too. Would you mind providing your login credentials in a secure note. I may able to check it.


1 Like

Hi Rad

Sure - how do I do a secure note to you

Don’t worry figured it out, messaged you a secure note:)

Hi @durhamld,

You should select the category in your EG’s source setting else it won’t be included in the filter. It’s currently not selected.


Great thanks Rad

How do we show more than 5 Portfolio Category buttons/filters at a time?

Hey @durhamld,

All categories should be displayed out of the box. Please ensure everything is up to date according to our version compatibility list at Please follow the best practices when updating your theme and plugins. See for more details.

After that, check if the issue persists.


Hi Christian

I’m unable to validate my theme purchase, please see attached

Hi There,

Thanks for writing in!
Please check this article for validation connection issue.

Hope this helps!

Unfortunately no it’s not helpful, haven’t encountered this issue with any other theme - please can you provide a solution or fix this?

Hi There,

I couldn’t replicate this issue on my end. The filter buttons are showing more than 5:

You could try testing for a plugin conflict. You can do this by deactivating all third party plugins, and seeing if the problem remains. If it’s fixed, you’ll know a plugin caused the problem, and you can narrow down which one by reactivating them one at a time.

Let us know how it goes!

I’m having the same issue – checked fire wall and F open is enabled


Have you tried adding &x-verbose=1 to the url?

This will reveal helpful error messages, please let us know what you are getting.


Hasn’t helped, we want all 6 categories to be available in the dropdown, please can you fix this? Not sure why something so simple is so difficult ;/

Hi @grubtribe, that requires manual installation of the latest theme. It’s from the old version (4.0) of theme where the validation feature is outdated (not matching with our latest validation processing in our server). Please do install the latest theme and cornerstone manually.

@durhamld, It’s because you set the page rows to 3 which 5x3 = 15 for first page. And the 6th item which is the isn’t displayed. Hence there is no Virtual filter as there are no items for that category. I went ahead and disable it in Grid Settings > Pagination. All items and filters are now displaying.

BUT, if you wish to retain that 3 max rows, then you should drag and drop the pagination too (not just the Filter 1) so users can go to the next page where other items and filters are available.


I’ve tried manually updating to the new version of the Theme following the steps listed, but when I do, the Customizer breaks ;/

It just loads a white screen.

Please advise

Works before we upgrade and all PHP INI settings are fine double checked before posting


Please set wp-debug to true in wp-config.php file and try updating again.

define('WP_DEBUG', true);

Once you change this, the white screen will now have errors, warnings, and notices. These may be able to help you determine the root cause.