Hover Box Not Working


I have a problem with my staging site page The hover box sections are full width and I should be 3 sections in a row as per the live site http://jimf.je/soap-box/

Please can you advise

Hey @jimfmedia,

I see you’re not using the same version of X and Cornerstone as in your live site. I’m not sure what Visual Composer you’re using in both sites also so first, please ensure that everything is up to date according to our version compatibility list at https://theme.co/docs/version-compatibility. Please follow the best practices when updating your theme and plugins. See https://theme.co/docs/how-to-update for more details.

If updating everything doesn’t help, please give us the following info for both the live and staging sites in a Secure Note

  • WordPress Login URL
  • Admin level username and password


Hey @jimfmedia,

It looks like there’s a conflict between Visual Composer and your staging server. I deactivated all plugins except Visual Composer and switched to the default WordPress theme but Visual Composer is still broken.

Would you mind copying your site to a different server and checking if the issue will persist in there? Also, please try setting up a fresh WordPress install, still in a different server and recreate the hover box portion. If the issue will persist, this is probably a Visual Composer bug and if that’s the case, we’ll report it to the Visual Composer developer.


Ok I have now created a fresh WP install on

I have loaded X theme and a child, connected the X account and brought all plugins and core up to date.
I can not access the theme options and get an error as follows. I havent restored the site yet as I will just select certain pages.


Not Found
The requested URL was not found on this server.

Apache/2.4.41 (Unix) Server at Port 80

Hey @jimfmedia,

There’s probably a problem with your setup. It’s not only the theme options having the problem. It’s the whole staging site. Please have your web host fix it.


This is a brand new fresh install ie not the first staging site I mentioned. The webhost has checked and they say nothing is wrong at their end.
Please can you advise.

Hi @jimfmedia,

Regarding this staging URL (

That is a server-side setup issue, please check the URL if that is correct, or if that staging was really set up properly.

Regarding the issue here (

Your WPBakery Page Builder is a few updates behind. You can update this by deactivating and deleting it, then navigate to X > Validation > Extensions and reinstall the WPBakery Page Builder.

You need to validate your X theme first though to install these extensions. You can add your staging URL on the licenses page.

Product Validation

Hope it helps,

Thats the previous URL. You asked me to install WordPress and X them on a new server which I did on

Please can you check that URL and not

I have now received an automated WordPress email suggesting the error. I have copied it below.


Since WordPress 5.2 there is a built-in feature that detects when a plugin or theme causes a fatal error on your site, and notifies you with this automated email.

In this case, WordPress caught an error with one of your plugins, Cornerstone.

First, visit your website ( and check for any visible issues. Next, visit the page where the error was caught ( and check for any visible issues.

Please contact your host for assistance with investigating this issue further.

If your site appears broken and you can’t access your dashboard normally, WordPress now has a special “recovery mode”. This lets you safely login to your dashboard and investigate further.

To keep your site safe, this link will expire in 1 day. Don’t worry about that, though: a new link will be emailed to you if the error occurs again after it expires.

When seeking help with this issue, you may be asked for some of the following information:
WordPress version 5.3.2
Current theme: x (version )
Current plugin: Cornerstone (version 4.1.2)
PHP version 7.2.25

Error Details

An error of type E_ERROR was caused in line 31 of the file /home/sites/jimfdev.je/public_html/wp-content/plugins/cornerstone/includes/extend/portfolio.php. Error message: Uncaught Error: Call to undefined function x_get_option() in /home/sites/jimfdev.je/public_html/wp-content/plugins/cornerstone/includes/extend/portfolio.php:31
Stack trace:
#0 /home/sites/jimfdev.je/public_html/wp-includes/class-wp-hook.php(288): cs_portfolio_init(’’)
#1 /home/sites/jimfdev.je/public_html/wp-includes/class-wp-hook.php(312): WP_Hook->apply_filters(NULL, Array)
#2 /home/sites/jimfdev.je/public_html/wp-includes/plugin.php(478): WP_Hook->do_action(Array)
#3 /home/sites/jimfdev.je/public_html/wp-settings.php(523): do_action(‘init’)
#4 /home/sites/jimfdev.je/public_html/wp-config.php(90): require_once(’/home/sites/jim…’)
#5 /home/sites/jimfdev.je/public_html/wp-load.php(37): require_once(’/home/sites/jim…’)
#6 /home/sites/jimfdev.je/public_html/wp-admin/admin.php(34): require_once(’/home/sites/jim…’)
#7 {main}

Hi @jimfmedia,

Yes, the is up now, but the credentials provided above did not work for this staging site, please check.


Hello @jimfmedia,

The password is still incorrect.

Please double check it.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.