Home page keeps showing "A conflict on front end..", other pages do not

Hi there,

I have installed X into a subdomain on my site and all seemed to be going well as per previous use on the main site. After creating a new home page editing and so forth it all seemed fine. When I attempted to go back to the page and edit it started producing the 'A conflict on your front end of your site has prevented…" error.
I had only a couple of addons installed so deactived them - did not help.
I deleted the page, started again and again it worked fine over a period of time, Then next day, same issue.
I tried increasing the response time
Tried uninstalling Cornerstone and reinstalling.
Tried pretty much everything on support forums, check formatting, removing images etc… but with no luck.
The strangest thing is that I can create and edit other pages, just not the home page. I have set different pages to the home page and they seems to be fine and can be edited - just not the actual ‘home’ page.

Site is maytube.maytec.com.au

1 Like

This is exactly the issue I am having at the moment. Have you managed to sort it out? I can’t seem to get anyone to help me figure out what to do.

UPDATE: I have just updated X Theme to newer version and it seems to be working now.

Hi there @MarkoMayTec,

Thanks for writing in!

Have you followed these steps?

2: If you have any caching plugins make sure they are deactivated for testing purposes and ensure all caches are cleared.

3: If you are using Cloudflare make sure it is in development mode. If you aren’t sure what cloudflare is, you can ignore this step.

4: Remove any custom CSS/JS added. A small syntax error will prevent the preview from loading.

As it’s just the Home Page, do you have any custom code on that page, or a specific element in use? Maybe you have a raw content element that executes a shortcode from a plugin?


Having spend a lot more time trying to resolve this, I’ve worked out that it’s not the page itself but rather how many elements are being put into it that’s the problem. There seems to be some kind of limit to how many sections/rows/elements are on the page before it starts to create the problem.

As for your reply, I mentioned I had searched for known issues, so yes to all your questions. I have added a few small pieces of custom CSS since, but this seems to have no bearing on the issue.

Hi there,

We have just released an update for X Theme 5.2.4 and Cornerstone 2.1.5 which address the bugs in the previous version.

Kindly update to the latest version and let us know how it goes.

Also , we have a new article with some troubleshooting tip which you can find here:

Hope this helps.

Still doesn’t work. Now I am getting the below. What page cacheing? I built an entire site with cornerstone/X (maytec.com.au) previously with no errors and I can’t even get started on this one as I continually have problems preventing me from even making any progress. Can we get this sorted ASAP as I have now wasted 2 weeks with this issue!

The preview was unresponsive after loading. This is most often related to a plugin conflict or aggressive page cacheing.

Origin URL: http://maytube.maytec.com.au

Preview URL: http://maytube.maytec.com.au/

Same issue here. My thread: https://theme.co/apex/forum/t/cornerstone-error-a-conflict-on-front-end-of-your-site/14112/12

If you wait, the page loads behind the error message. I keep asking for them to add an [X] or [CLOSE] at the top right of the error message so I can dismiss it and work on my pages.

If I click “Try Again” it reloads the page, no error message, but everything that had previously loaded before disappears, and only the header and footer are displayed. Can’t edit the page.

They are in denial that all of these issues are because of the cornerstone update and are trying to lay blame on plugins, caching, hosting, etc… anything but them.

Hi there,

Judging from the Original URL and the Preview URL it seems that the problem is the HTTP/https difference between two. Would you please kindly make sure that you do not have any reference which is HTTP and makes sure all of them are https? You can use plugins such as:

We will be more than happy to investigate more in details and be able to help you with the problem you are experiencing.

Kindly get back to us with the information below using the Secure Note functionality of the post:

  • WordPress Dashboard URL
  • WordPress Dashboard Username
  • WordPress Dashboard Password
  • The Nam of the Page to Check

Thank you.

Hi, @emmasanimals and @mchll9898,

As there are many factors involved regarding the Builder Preview problems I suggest that each of you open up a separate thread and give us detailed information about your experience and we will be more than happy to follow up the case.

Just make sure that you guys updated the X theme to version 5.2.4 and Cornerstone to version 2.1.6, and if you use Pro to version 1.2.6.

For further information about having a good experience using our support system kindly read the Hijack section of our support guideline:

Thank you and we appreciate your patience and understanding.

I linked my thread. No one has replied in 2 days.

Hi there,

Kindly be patient and one of our colleagues will follow up the case. It will not have any impact to have the link of a thread to another one, there is a queue of the threads which will be taken care of in First in First Out fashion.

Thank you for your understanding and patience.

Right, so I have done these things you’ve asked and another week has gone down the drain. Is anyone going to get back to me on this?

Hello There,

Sorry for the held up. I have logged in and found out that you have a different dashboard url and the site url. Please keep in mind that Cornerstone will use the general settings and since your dashboard is using https, the editor did not load because of CORS issue.

So I went ahead and changed the urls in your settings. And another thing, I noticed that you are using CloudFlare, this may have caused aggressive page cacheing. Please make sure that you are using the best recommended CloudFlare setting which you can check it here:

Hope this helps. Please let us know how it goes.

The cloudflare was being used with the cache set to development mode, so it didn’t have anything to do with it. It would have helped me if you could have done a quick check while you were logged in as it would have taken 10 seconds to see if it worked. It doesn’t!

Hi there,

We checked which is why we found out about your site’s URL, and you can’t really be mixed both HTTP and HTTPS and cornerstone will not really work. But the thing that we can’t check and the test is your CloudFlare configuration. So please provide your CF login credentials too and we’ll be more willing to check it.

I know you said that you set it to development, but most users said that too and in the end, it’s still CF’s fault. I’m not saying it’s CF’s fault in your case, but like you said, we should do a quick check.


Have updated details for access.

Hi there,

First of all, thank you for your patience and cooperation regarding this matter as it took much time and we understand that this can be frustrating.

We are doing our best here to find out why this is happening in your environment, as you already see we ruled out different possible case scenarios.

I did spend much time to investigate and troubleshoot the case and I finally found out there was a problem of some kind regarding the Permalinks of the website. My guess is that it was cached somehow and prevented the Cornerstone to act normally. I set the permalink to post name and saved the setting and the homepage showed the preview with no problem.

To make sure that the editing experience is also correct, I used the Templating system of the Cornerstone to add the homepage as a Cornerstone template.

Then I added a new page called Homepage Test and imported the template into that page. Then I did an edit and changed the Australia to Australiaa, it changed with no problem.

I think I pinpointed the problem and you should not have any more issues using the Cornerstone.

I want to express my appreciation for your patience and cooperation regarding the troubleshooting process as it took a long time.

Finally, I suggest that you open up another thread if you encounter any more side effects as this thread is jammed with other customers chiming in and is difficult to maintain. I am sure if you have additional questions and you open up a new thread, I or my colleagues will have a better opportunity to serve you as you deserve.

Thank you.

Seems to be working now. Thanks for your efforts!

Hi @MarkoMayTec,

Happy to hear that.

Feel free to ask us again.


This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.