Hi there,
We have several sites built with X. After shifting to SSL a while back we had issues getting the site URLs to all load as HTTPS - there is a thread I started here were it was eventually resolved:
Recently after editing, or updating, all the pages are showing the same errors again, just on one of the sites:
When I use an online took to find out why…
https://www.whynopadlock.com/results/050b12e8-33f2-4c64-93d2-d591036ef3fe
…I get things like
“An image with an insecure url of “http://www.evergreen-hakuba.com//wp-content/uploads/2017/08/mtb_hakuba_evergreen.png” was loaded on line: 364 of https://www.evergreen-hakuba.com/jp/.
This URL will need to be updated to use a secure URL for your padlock to return.”
But when I search the Page Source the images mentioned are all loading not with “//” but with “/en/” which then redirects to “/”
ie
https://www.evergreen-hakuba.com/en/wp-content/uploads/2017/08/mtb_hakuba_evergreen.png
loads as
https://www.evergreen-hakuba.com/wp-content/uploads/2017/08/mtb_hakuba_evergreen.png
Can you please help me troubleshoot this? The same error is on every page with different images, I can’t go through and change them all, but cannot work out how to run a search and replace on this.
Thanks in advance!