Help! Font Awesome icons suddenly not showing up!

I recently moved a website from testing and everything seemed to be working fine. Two days later I’m looking at the website and the FA5 icons are not showing up in Chrome and Firefox. They DO show up in Safari.

It does appear to be a cross region issue and I did add your suggested COR to the htaccess, but it doesn’t appear to be working.

Any suggestions?

Hi Admin,

Thanks for reaching out.

Can you let us know what’s the website URL you are currently working on so that we can help you troubleshoot your issue

Hope that helps.

Thank you.


Another issue I noticed is that the FA5 icons that are “regular” or “light” do show up.

ONE MORE ODD THING. The FA5 icons appear in the edit content pages, but when you preview the pages, just squares appear (chrome).


I checked couple of your pages in Chrome and I see all of your icons correctly. If you’re seeing some font awesome icons and some not then this issue usually happens if you’ve added the icon markup manually. As of Font Awesome version 5 they split icons into multiple fonts. This can be fixed by changing instances of the data-x-icon attribute to one of the following:

data-x-icon-b for social icons.
data-x-icon-o for outline icons.
data-x-icon-s for solid icons.

The original attribute data-x-icon will still work for solid icons as a fallback but we’ve updated everything for consistency.

Hope this helps!

Yes, I added some code to my htaccess and it fixed the issue. I think. But it doesn’t make any sense since I was only getting COR warnings for the FA solid-900 files and NOT the light or regular. If it was a COR issue, wouldn’t the other FA fonts not work? I also could view the icons in editor but not on the live site or preview. Maddening. I still don’t understand why.

I did not enter the icons manually.


As previously told by my colleague, I also found the Icons are working fine in your pages. And also found that the Icons are updated to the code which explained to previous post.
Please let us know if you are still having any issues on this.


Hello @HSLLC,

Is your issue resolved already? Please make sure that you have enabled the font awesome and its icon weights in X > Theme Options > Miscellaneous > Font Awesome. If nothing is helping, provide us access to your site so that we can check your settings. Please create a secure note with the following info:
– Link to your site
– WP login URL
– WP username
– WP password
– WP Administrator Role

To know how to create a secure note, please check this out: How The Forum Works

Best Regards.

I had the same issue even after I cleared cache. But I just had to logout and login again and after that I got the Font Awesome in my Miscellaneous. Thank you! This was helpful :slight_smile:

You are most welcome!
It’s good to know that the icons are working now.


By withdrawing the post mean that the issue is already solved. If you have any other concerns, feel free to reach us.

Thank you;

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.