Header Footer Not Assigning

I have cleared cache, used incognito, tried assigning individual pages, both headers and footers are behaving very weird.

I am getting really frustrated with this. I use remove, global, individual assignments and it will not change.


I don’t want to remove the other header versions to simplify the area because I want to save those versions.

please help i am on deadline

Hello There,

Thanks for writing in! It seems that there is a plugin adding some element structures on the page. To assist you better with this issue, would you mind providing us the url of your site with login credentials so we can take a closer look and your site?

To do this, you can create a secure note with the following info:
– Link to your site
– WordPress Admin username / password

To know how to create a secure note, please check this out: https://theme.co/apex/forum/t/how-to-get-support/288

Thank you.

I deactivated all plugins and still the issue persists.

Hi There,

I’ve created a new header(named as Contact) and assigned it to the contact page.

The new header is working fine now:

Could you please clear all the caches or try in another browser then check again?

Let us know how it goes!

I re assigned everything and it is still not working. There is one header for the home page with extra text and then another header for sub pages they are both labeled “plain”.

Hello There,

I am seeing two different header for your homepage and your contact page.

Could you please elaborate which header is not displaying in which page? And maybe also clarify what should we expect to see in the header of the page.

Thank you.

Plain Header Home is a different looking header assigned global. The split nav with center logo is the old header.

Hi @verobeachmarketing,

I still don’t get what’s the issue, both plain labeled header are assigned. For example, the Plain Header Sub Pages is assigned to the contact page, and the header displays okay in the front. Would you mind providing more clarification on how to reproduce this issue?


When I edit the Plain Header Home, I do not see the split menu as you have shown above. The split header with the logo is the old version and should show anywhere.

Hi There,

The home page is using this header: http://cs2488.mojohost.com/ji2e.com/public_html/pro/#/headers/174

And another pages are using this header: http://cs2488.mojohost.com/ji2e.com/public_html/pro/#/headers/208.

I still couldn’t find what’s the issue you’re facing. Please provide more clarification on how to reproduce this issue.


I want the 204 header assigned to the home.

I just removed it and added it back and it is now working. Maybe because I was using it as global I don’t know. This is the 20+ sites I have built using Pro and never have I had this issue.

Glad to hear that it’s is working fine now. :slight_smile:

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.