Grid not working

Hey! I’m using learndash to show my online courses, and when I use the grid shortcake to present them it looks completely off:

But this only happens when I use the pro editor. If I put this shortcode on classic editor page/post, it looks totally fine. Any ideas what’s happening there?

Hi Morr,

Thank you for reaching out to us. Try pasting your shortcode in Raw Content element instead of Text element. Sometimes additional tags are added while pasting the shortcode in the Text element or switching between HTML and Rich Text editors.

Let us know how this goes!

Hey! Did that, nothing changed…

Hello Morr,

It seems that the styling of the grid were not loaded in the page. Are there any settings in your grid plugin to load up the resources globally? To better assist you with your issue, kindly provide us access to your site so that we can check your settings. Please create a secure note with the following info:
– Link to your site
– WordPress Admin username / password

To know how to create a secure note, please check this out: How The Forum Works


There are no such settings that I know of. I sent you the login info.

Hi Morr,

Your test page is now working like a charm

The issue is when the plugin finds the shortcode in post_content but not possible with builder elements since the data are saved somewhere ( post_meta ).

Then we find a workaround and found out that the plugin should work with the classic element as the data are still saved within post_content

To trigger the classic section you should do this “While you’re hovering to Add Section, press CTRL or ⌘ and Add Classic Section will appear

Thank you.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.