Glitchy masonry blog style when using The Grid and X pro

Hi, I use the grid plugin for my blog post and noticed that the spacing between masonry posts are sometimes unequal. see example below:

How to constrain the gap between all post to remain the same?


Hey Lio,

It looks like the Grid calculates the position before some contents are loaded so the calculation is wrong.

We first need to ensure that this issue is only in The Grid plugin so please switch to the parent theme and test for plugin conflict by deactivating all 3rd party plugins and seeing if the issue persists.

If the issue persists after that, please give us the following information in a Secure Note.

  • WordPress Login URL
  • Admin level username and password

You can find the Secure Note button at the bottom of your posts.


Hi Christian,
I switched to the parent theme, same issue.
I disabled most plug-ins with the child theme, same issue

Hello Lionel,

Thanks for updating in! This issue could be coming from your Site Accelerator which is a module of the Jetpack plugin. Kindly go to Jetpack > Settings > Performance and temporarily disable the Site Accelerator module. If nothing is helping, provide us access to your site so that we can check your settings. Please create a secure note with the following info:
– Link to your site
– WP login URL
– WP username
– WP password
– WP Administrator Role

To know how to create a secure note, please check this out: How The Forum Works

Best Regards.

Hi Ruenel,

No change after disabling the Site Accelerator module, also same after I disable the whole plugin.

I noticed that if I only load one blog post on my site / page and let the other posts load when scrolling down, they load correctly (same spacing between them). It seem to be something with the first time that Grid and the page load.

I do not understand… My site is very simple: 1 page, 130+ blog posts, archive, search and index grids and basic widgets as a sidebar… basic CSS tweaks only. What could go wrong?

Hi Lionel,

It is very difficult to help you, without checking The Grid setting at your end. It might be a setting(s) that resolve the issue. So to get further support, please provide your site credentials like it has been already asked twice before.

If you are not willing to share the details of the live site, please copy your live site to a staging server and give us access in the secure note including for further investigation:

– WordPress Site URL & Admin URL
– WordPress Admin username/password

To create a secure note, click the key icon underneath any of your posts.



I was about to share my access details… however, I installed the health check plug-in to use their troubleshooting mode, and it appears that the issue is related to plug-in smush which I had installed for image compression / optimisation. I removed smush and installed another image optimiser plug-in and the issue is not reproduced.


Hi Lionel,

We are just glad that you have figured out a way to correct the said issue.
Thanks for letting us know!

Best Regards.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.