Glitch with New Rows - Column Changes Not Taking

See video.

Pretty basic - on an existing site, we created a new section, added two rows to the section. The bottom row we never touched. Top row was set as 2/3 + 1/3 split. Added one element to each column. We went and edited a different element not in this section. Came back to this section and changed the column config in the row to 1/3 + 1/3 +1/3. It did not take. We tried other configs, they did not take. We saved and reloaded the page, the row’s column config will not change not matter what. (??)


Page in question uses no custom CSS or javascript.

Just to add to this - yeah, seems to be a pretty big glitch that my team is experiencing with the new rows. We’re starting to add these in for the first time on projects and have now experienced 6 instances between us where once you set the row’s column config, going back later results in the column being permanently locked into whatever was originally set. The only workaround is to create a new row with the # of columns you want and then move everything there.

While I was typing this, one of my devs sent me this gem (attached). Check out the 3 columns of stuff with the 4 columns overlaid on top of it. LMAO! Pro seems to have a split personality problem. WTF??

(Just to be clear, this 3-column-but-also-4-column row has no row elements or child rows. It’s just 3 rows going down. Screenshot taken in full desktop mode. No breakpoints for anything coming into play here.)

Hello @co50,

Thanks for writing in!

I have tried to replicate the issue on my end and I could not see any issues.

I created a section and added a background color. I inserted a row with two columns in it. I added a white background color for the row and a grey color for the columns. This is to identify which is the column and the rows within the section.

Kindly add some background colors for your section, rows and columns to easily spot the changes as you change the column layout.

Please let us know how it goes.

I literally showed you a video and a screenshot of it. I proved it happens. Multiple devs on our team have experienced this multiple times, which is our threshold for reporting it. It’s a confirmed bug. Likely related to the same memory issues that plague Pro on large sites that affects lots of other things. But again, I sent you a screenshot. Do you think I Photoshopped it? If not, then I’ve proven to you that the bug exists. It likely will not show up on a blank site with few elements. Pro’s problems become apparent on larger sites with many elements.

Right now we have way too many issues in the Support queue with Pro and we cannot provide extensive bug squashing assistance, unfortunately. You guys will need to flesh out these bugs - or hire us so we can compensate for the time. We’re just reporting them. And while you may not be able to reproduce the bug yourself, trust me. It’s there. And you’ll eventually fix it.

EDIT: Here’s another video of the issue:

Very easy to reproduce on busy sites.

Hi @co50,

Yes, I can see the issue on your video. Although, like Ruenel, I can’t duplicate this too. We need to investigate further. Can you share the device, screen size and OS you were using? We need to gather more details before reporting the issue. We’re sorry for the inconvenience, though rest assured we will investigate this matter.

It might also help if you can share the URL and credentials of the site inside a secure note so we can check it directly. Thank you.

I use Windows 7, Chrome 77, 3840x2160 screen resolution (display text set to 125%).

Secure note attached with login.

Hi @co50;

The username/password you shared does not have enough permissions so I can not access the pages and I do not see the Pro menu at all.

I checked the last video. Please go to time 0:23. You were changing the Layout options there, but if you see just above that section it shows that you only have one column. Please add another column by clicking the + Add Column link and you will have more than one column to play within the layout options:

I also suggest that you read the section below of our release notes FAQ:

With the new Row element, why do I only see 2 columns if I’ve selected 4?

I need to go over the page in question to make sure what is happening, what I mentioned above is what I see in the video.

Thank you.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.