Gallery and video not displaying in correct location in full-width portfolio-item page

Hello support, please help!

I can’t get the gallery to display in full-page format. The tiled gallery keeps getting pushed to the right of the page and I want it to appear underneath large featured image. Ideally, I don’t even want the featured image to appear in different size above the gallery. It would be great if it just appeared inside the tiled gallery itself.

This is also happening in the video portfolio-item pages. The video gets pushed to the right of the page :frowning:

How do I fix this? I tried everything in the X Ethos customization tools and options.

Thank you!

Hey There,

Would you mind providing us with login credentials so we can take a closer look? Please provide following information:

Set it as Secure Note

  • Link to your site
  • WordPress Admin username / password

All the best!

Here’s another example of how the problem appears on the video page -

it says ‘video source missing’ and all the videos are pushed to the right and stretched down.

thanks for looking into this! i submitted the login credentials in secure note.


Hi There,

When we select Video under Portfolio Item Settings > Media Type, a video settings will appear like below.
That is where we’re going to put the video we wanted to add. It is showing Video Source Missing because that content for that part is not added. It will not get it’s the video from the content are where you have added the code for the video right now. Video Portfolio Item Settings is not available on your portfolio item when I checked. You can enable it on Screen Options on the upper right part.

After you have done that, the video will now show on the left part and then the content will show on the right where the current video is. That is the default design for portfolio item using Ethos stack.

Now, if you want the video on top and the content below it and both fullwidth, try adding the following custom CSS:

 .single-x-portfolio .entry-featured, .single-x-portfolio .entry-wrap {
    width: 100%;
    padding: 0;

Hope this helps.

That only partially solved the problem :frowning: I added several videos into the ‘embedded video code’ area like you suggested, but only one video is displaying. I need ALL the videos to line up underneath each other on the page. And also the custom CSS code you sent isn’t making the videos fullwidth :frowning: This is how it looks now -

Also, what about the photography gallery pages I asked about in my original question? I have the same issue of the gallery being pushed to the right, whereas I need the gallery to display fullwidth from left to right. Here’s the issue -

Thanks so much for your help!

Hello There,

Thanks for updating in! Please be advised that our portfolio item page layout in Ethos stack is divided into two columns. Namely the featured media which is 68% and the portfolio content area which is just 32%. This was showcased in one of our demo site which you can find it here:

If you want to have a fullwidth layout like this:, please add the following CSS code in the X > Launch > Theme Options > Global CSS (

.single-x-portfolio .entry-featured,
.single-x-portfolio .entry-wrap {
    float: none;
    width: 100%;
    padding-left: 0;
    padding-right: 0;

Hope this helps. Please let us know how it goes.

Thank you so much, I’m starting to progress! Now there’s a problem with how the photos are loading… As you can see in the links below, one of the photos from the gallery appears on top of the page in full-width, followed by huge white space after which the tiled gallery continues below. You can see it here:

How can I fix this?

Thank you!!!

Just a note to add to my previous question: the top image that loads above the gallery isn’t a featured image, just seems to be randomly picked from the gallery and added at the top after gallery loads. I need for these portfolio-item photography gallery pages to only display the gallery itself without full-width image above.

more examples of the problem:

Thank you so much for your help!

Hi There,

This is because on the portfolio item settings, you have chosen Gallery under Media Type. This will display all attached image on the portfolio item on top of it as fullwidth flexslider. Then on the content you have added another tiled gallery. The white space you were seeing is the space intended for the tiled gallery you have added on the content area, it is just not loading yet. There page is having a hard time loading everything. You might want to check this: to improve performance of your site.

Hi again, thank you for your answer but I don’t understand it :frowning: If you take a look at this page here - - it is displaying my gallery correctly. It is set up exactly the same way as this page - - where the problem still occurs. What’s the difference? Can you please help me set up the gallery page to display only the tiled gallery alone, like in the first example.

Thank you!!!

Under your Portfolio Item Settings, choose Image for your Media Type then remove the Featured Image.


Hi again, thank you for the suggestion. Now the gallery portfolio-item page looks how I want. However, when I remove featured image from portfolio-item page it also disappears from portfolio-layout page :frowning: Please check how on this page the top left hand corner box for Oaxaca gallery is now empty without a cover image -

How can I keep the gallery page exactly like this - - but still have the featured or cover image appear on the portfolio-layout page?

Please help! Thanks so much!!!

I see. In this case, custom CSS would be required. Please add this code in X > Launch > Options > Global CSS

.single-x-portfolio .entry-featured {
    display: none;


Hi There,

Did you implement the suggestion already? If you still have questions, we’re always here to help.

Yes, I did implement and all seems to be working - thanks so much for all the help and suggestions!

I do have another question - how do activate one-page navigation? I activated it on every page, but there’s no change…


Hi There,

On which page you want to add a One Page Navigation?

You need to add IDs to your sections and add custom links to your menu.

After on the page you want to add a One page Navigation menu, you need to click edit page and scroll down and select the menu you created as your One Page Nav Menu

On your case you need to have a second menu, because your website setup does not seem ready for One Page Navigation style website

Please let us know more details.