First tab no longer open by default


I recently updated Pro. Now, pages with tabs no longer open the first tab by default like they used to. E.g.

Is there a fix for this?

Hi Alex,

Thank you for reaching out to us. I checked you pages and it seems like a conflict which is preventing the first tab to open up. Please check for the following first:


If you still have problems then please get back to us with the result of the steps above and URL/User/Pass of your WordPress dashboard using the Secure Note functionality of the post to follow up the case.


Hi @nabeel

Still no luck I’m afraid. Shall I provide login details?


Hey Alex,

After doing the updates, always remember to clear all caches since you are using WP Rocket so that the code from the latest release is always in use. This will help you to avoid any potential errors. And please clear your browser cache too. You may use private browsing mode in testing your site to make sure that you are viewing the latest codes from the updates and not the cached version in your browser.

These links might help:

If nothing is helping, provide us access to your site so that we can check your settings. Please create a secure note with the following info:
– Link to your site
– WP login URL
– WP username
– WP password
– WP Administrator Role
- Confirmation that we can access and make changes to your site

To know how to create a secure note, please check this out: How The Forum Works

Best Regards.

Hi Ruenel

Replying with the details requested in a secure note. We have a lot of traffic this weekend so I will wait until Monday before providing these, as I don’t want any changes made over the weekend.


No problem.
Our staff will be standing by.

Hi Ruenel - attaching as secure note to this post.

Hi @ruenel, please can you let me know your IP so I can whitelist it?

Hi Alex,

I suggest that you copy your live website to the staging area so that we could help you debug your problem because we are afraid to edit or deactivate your plugins on your website which might cause an issue.

I also suggest that you disable the IP restriction in your staging area so that anyone in our stuff can log in without any issue.

Hope that helps.

Thank you.

Hi Marc

No worries, I’ve updated our dev site for this. Details in secure note.


Hi Alex,

I have gone through your website and found the pages are assigned with the customized Page Template which has been added through the modified child theme. It has been also found that the Tabs is used through the code not by using the Tabs element, and which has a missing x-active class for the first tab. Although we don’t support custom code and modified child theme, I went ahead and added the class in template-betting-landing.php which cause the page to load with the first tab active.

Please add the class in the respective page templates, to get the first tab to activate on those pages.

Hope it helps.

Fantastic - thanks so much for your help!

Hi Alex,

Glad to help you with this.


This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.