Extensions not showing in admin panel

Hello, I just did a fresh install of x and a child theme, then I activated typekit and it is not showing in the admin panel. I am using X 5.1.1 and I tried disabling my child theme to see if that was the issue but it still persists.

I tried also activating white label and under construction, since they appear the same way and they also do not show in the admin.

I just see Overview Launch and Cornerstone when I hover over X in the admin.

Thanks for any assistance,

Hey @Noaviv,

Would you mind providing us with login credentials so we can take a closer look? Please provide following information(Use Secure Note):

  • Link to your site
  • WordPress Admin username / password
  • FTP credentials

All the best!

Thank you, I have added the secure note.

Hi there,

Please validate your theme in order to access the extensions.

You may find more info here: https://theme.co/apex/forum/t/setup-product-validation/55

Hope this helps.

I have validated my theme and they are still not showing up.

I re-validated the theme and they didn’t show up. I also deleted and reinstalled the plugins afterwards and they are not showing up.

Hi There,

Sorry for the confusion. Every plugin will not list under X sidebar once you installed it. For example Typekit will be accessible under Settings section.

A plugin like slider revolution will have it’s own tab under the left sidebar of WordPress admin panel. Some extensions will be accessible through X tab.

Hope that’s clear.

oh thank you I see it now.

You’re welcome.

Hi Guys, I have same problem but in my case it’s related to

  • “Under Construction”

This is with the latest 5.1.1 X and using child theme. License is validated also.

This is a fresh new installation of WP with nothing in it so I don’t understand why.

Can you please look in to it?


We moved the Under Construction menu to Settings > Under Construction:


1 Like

I’ve noticed, all good, thank you for the reply…

I like it… it makes more sense when I think about it.

Love your work guys…

GO THEMECO :slight_smile:

You’re most welcome. :slight_smile: