Essential grid not saving any checkbox options for choosing Lightbox source

Hi guys, I recently updated Pro from 3.2.3 - all seems fine - and now Essential Grid to the latest, which I’m having a problem with.

Upon noticing that the grid’s lightbox isn’t opening as per usual, I found that the plugin isn’t saving any changes in the lightbox source order in the following manner:

Here is what I have selected before saving:

And after saving and getting ‘save successful’, when I come back to the lightbox menu I see the following:

…showing that it has simply discarded any changes I have made.

I tried disabling all of my plugins and renaming my pro-child functions.php, with no effect.

It seems I can change and save every other setting in the grid such as the name, alias, and all of dimensions and source settings.

However, the Ajax tab has a similarly styled checkbox list as follows:

…in which no changes will save either.

While these checkboxes seem to be the only issue, because I cannot select a lightbox source option and save it, I am seeing href="javascript:void(0);" when I inspect the lightbox toggle in my grid and this is why my lightbox is no longer working.

I can rollback to an earlier essential grid and everything will work, but I’d rather fix the issue and keep everything updated.

Would you have any ideas as to what could possibly be causing this?

My grid is over at

Many thanks!

Hi @daveisthemusic,

Thanks for reaching out.

The issue is only happening on your install because when I tried to follow the same settings to my staging environment I can’t replicate the issue you’re facing on.

I suggest that you copy your live website to your staging area so that we can troubleshoot the website without breaking your live website. After creating the staging area, please give us the following information in a Secure Note.

  • WordPress Login URL
  • Admin level username and password

You can find the Secure Note button at the bottom of your posts.

Thank you.

Hi Marc,

Thanks, I already added the secure note with login details at the time of creating my first post there; it’s affixed to the bottom. :slight_smile:

I don’t have a staging area, however feel free to login and troubleshoot because I’ve just setup jetpack in the last couple days and have my first backup stored. So, if anything happens to get worse, I should be able to simply roll back.

If you login and try to save any changes to those checkboxes in the ‘Catalog’ essential grid, you should be able to see the issue that I’m having (- you’ll need to refresh after seeing ‘save successful’ to see the error).


Hey @daveisthemusic,

This boils down to only Essential Grid and your web host. There’s no clear error that could lead us to the cause but I believe that there is an error logged in your server’s error log so please contact your web host to give you the server’s error logs and post the error log here in a Secure Note.

Please also give us cPanel access so maybe we could spot something unusual in your setup. Just note that we can’t guarantee a fix for server/plugin conflicts as we do not have control over the server.


Hi Christian,

I understand that there are no guarantees, but yes please - if you wouldn’t mind taking a look to see if anything jumps out at you on my server, that would be great - because the thing that seems pretty strange to me about this is that everything else in Essential Grid can save. I don’t have cPanel but Plesk; I’ll put my Plesk login in a secure note below.

Just to note, the only emails I’ve received from Plesk regarding any server errors was relating to yum updates failing - because CentOs 6 is end of life, they’ve changed their usual updates URL to /vault/. I’ve just edited a config file and the update has successfully completed. I think this probably didn’t change much on my server and wasn’t the cause of this Essential Grid error.

Apart from that, I’m not sure where you’re seeing this server error you mentioned - when you go into my Plesk, will you be able to see the error logs there as I have a VPS server? Or do I still need to contact my host?

Thanks again.

Hey @daveisthemusic,

The server error log is usually located in the root of the server. If you’re not familiar with that, please ask your web host also especially that I’m not seeing one on your site.

By the way, this is only an issue with your web host. I exported your broken grid and it works on my end. Saving works.

Please have your web host test the Essential Grid. If they could not fix the issue of their server, I’d recommend you move to another web host.


Hi Christian,

I really appreciate the advice, but I believe that I’ve ruled out my server being the issue. I created a working localhost clone of my website by downloading a Jetback backup of my files and database, and the same saving issue occurs when saving the grid offline. Somehow, it looks like this error is occurring with my Wordpress install, but not with the server itself - when checking the error log of my new local Apache server, it has no new reports after saving the grid. It seems that no server errors are taking place.

My local Apache server’s access.log keeps showing the following repeating lines, when I am just trying to save the grid:

::1 - - [12/Jan/2021:02:54:02 +0000] “POST /wp-cron.php?doing_wp_cron=1610420042.6385059356689453125000 HTTP/1.1” 200 -
::1 - - [12/Jan/2021:02:54:02 +0000] “POST /wp-admin/admin-ajax.php HTTP/1.1” 200 47
::1 - - [12/Jan/2021:02:54:09 +0000] “POST /wp-admin/admin-ajax.php HTTP/1.1” 200 74
::1 - - [12/Jan/2021:02:54:09 +0000] “POST /wp-admin/admin-ajax.php HTTP/1.1” 200 43916
::1 - - [12/Jan/2021:02:54:28 +0000] “POST /wp-admin/admin-ajax.php HTTP/1.1” 200 74
::1 - - [12/Jan/2021:02:54:29 +0000] “POST /wp-admin/admin-ajax.php HTTP/1.1” 200 43916
::1 - - [12/Jan/2021:02:54:42 +0000] “POST /wp-admin/admin-ajax.php HTTP/1.1” 200 47
::1 - - [12/Jan/2021:02:54:49 +0000] “POST /wp-cron.php?doing_wp_cron=1610420089.0473470687866210937500 HTTP/1.1” 200 -
::1 - - [12/Jan/2021:02:54:48 +0000] “POST /wp-admin/admin-ajax.php HTTP/1.1” 200 74
::1 - - [12/Jan/2021:02:54:49 +0000] “POST /wp-admin/admin-ajax.php HTTP/1.1” 200 43916
::1 - - [12/Jan/2021:02:55:02 +0000] “POST /wp-admin/admin-ajax.php HTTP/1.1” 200 47
::1 - - [12/Jan/2021:02:55:22 +0000] “POST /wp-admin/admin-ajax.php HTTP/1.1” 200 74

So just to check these files were ok, I replaced my cloned local admin-ajax.php and wp-cron.php with clean versions from the installation zip file - but that didn’t help.

On my local site, I also turned off all other plugins and deleted my child’s functions.php. I changed the theme away from Pro and back again. I tried with both the same grid you have imported and creating a new one, but in all circumstances the saving error still occurs.

Any other ideas to why this could be working fine on your Wordpress installation, but not on my offline server?


Hi @daveisthemusic,

As you are working on the local environment, it will be very difficult to assist you without examined it if none of the above works for you.
In that case, I would suggest you upload the files to a server and please provide login credentials for your site in a secure note to examine it further, including:

– WordPress Site URL & Login URL
– WordPress Admin username/password

To create a secure note, click the key icon underneath any of your posts.


@christian I wanted to reply directly to you as you have been the most helpful with this topic; the last reply from tristup asked me to provide server login details which were provided back in post #1. I feel we are heading away from solving it by involving others, especially because you have already taken the time to test the problem on your end by importing my grid and saving successfully (thank you for that).

By the way, this is only an issue with your web host. I exported your broken grid and it works on my end. Saving works.

If you read my last post before this one, you will see that the issue is replicated on an offline, cloned backup of my website and database running on a localserver that is reporting no server errors. So it seems that this assertion about the web host creating this problem cannot be correct - if the problem also occurs offline, the problem must exist somewhere in my wordpress install, and not in yours.

If the error is occurring within my wordpress installation - do you have any ideas on how to locate the error without reinstalling wordpress from scratch? I know this will fix it if it works fine for you, but I don’t want to have to build my site from the beginning just because of this one error.


Hi @daveisthemusic,

I suggest that you delete all your WordPress files in your local environment folder except for the wp-content folder and wp-config.php files. Then download the new files from WordPress and copy all the files to your local environment folder except for the wp-content folder from the newly downloaded WordPress files. In that way, you will have updated files that might able to help you fix the issue you are facing on.

Hope that helps,

Thank you.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.