Essential Grid items not linking

None of my grid items are linking to their corresponding pages. You can tell it’s a link, but nothing happens. I’ve turned off all of my plugins to test, but nothing works. This is a new issue and the only thing I’ve updated is the Pro theme (after I noticed the grid wasn’t linking). Do you have any ideas what I can do next?

https://downeastwatercolors.com/seascapes

Hello Beth,

Thanks for writing in! Regretfully the given credentials do not work for us. It seems that the password is incorrect. In the meantime, please edit your grid skin and make sure that the button link is set up properly.

To be familiar with the Essential grid Editor, kindly check this documentation:

Or you can check out this video tutorial:

By the way, I also noticed that there is a JS error on the page because you have inserted this broken JS code:

 grecaptcha.ready(function() {
	if ($(‘div.wpcf7’).length) {
		$(‘.grecaptcha-badge’).css( “display”, “block” );
	}
});

The code above is using incorrect quotes. Please have it updated and use this one instead:

grecaptcha.ready(function() {
	if ($('div.wpcf7').length) {
		$('.grecaptcha-badge').css( "display", "block" );
	}
});

Please note that custom coding is outside the scope of our support. Issues that might arise from the use of custom code and further enhancements should be directed to a third-party developer.

Best Regards.

Thanks for the JS correction! I made the change.

The settings on my grid look just like the screenshot, so I still can’t figure out why the linking isn’t working. It seemed to happen overnight, without any plugin updates. I updated my theme to see if that would help, but that didn’t have any effect.

I’m sorry about the password - I’ve updated and am including here.

Thanks for your help! I’m working on a new site, but really need the current one to work so customers can view my paintings.

Hi @bethw789,

I check your Essential Grid skin and the icon link is set to none, I went ahead and link it to posts then it is now working fine.

image

Hope that helps.

Thank you,.

1 Like

Bless you!!! That’s so weird because I hadn’t touched a thing. It works now and I can breathe easy. Thank you so much - I appreciate this so much. You are my favorite person today!!

Hi @bethw789,

You’re welcome and it’s our pleasure to help you! If you have any other concerns or clarifications regarding our theme features, feel free to open up a new thread.

Thank you.

1 Like

Hello. I’m having the same issue with Essential Grid links to page URLs no longer working with the latest update. I’ve attempted the changes to the skin that you recommend, and I’m not even seeing the same option to “use Tag” shown in your screen-caps. Updated to Essential Grid Version 3.0.12. Other grid covers that i’ve set up as lightbox triggers are still working, just not the ones that have links to other pages.

Hey @ggunn,

We first need to know if the issue is only with the Essential Grid and not affected by our theme or other plugins. To do that please do and confirm that you’ve done all of the troubleshooting steps listed in our article here https://theme.co/docs/common-issues.

If none of the troubleshooting steps solve the issue, please open your own thread so you could give us WordPress credentials in a Secure Note. In your thread, provide us the following information.

  • Name of the grid you’re working on
  • WordPress Login URL
  • Admin username and password

You can find the Secure Note button at the bottom of your posts.

Thanks.

Hello @christian

I have deactivated all my plugins aside from Essential Grid and the problem continues, unfortunately.

Hi @ggunn,

It is advisable to create your own thread so that we can address your issue properly. Please note that when you added a piece of information in the secure note from someone’s thread, the one who posts the thread can see your credentials. That being said, I remove your secure note information for security purposes and just add it in the new thread.

Thank you.

@marc_a I didn’t realize a secure note was visible by the OP. Thank you.

Hi @ggunn,

You’re welcome!