Essential grid and Revolution slider not working after latest updates

I do have a valid license but the update is not showing.

Hi @marketfresh,

I suggest that you will create a new ticket, then please give us the following information in a Secure Note in the newly created ticket.

  • WordPress Login URL
  • Admin level username and password

You can find the Secure Note button at the bottom of your posts.

Thank you.

Hi Cramaton,

Of course I do have a valid license, but the updates have mysteriously not showed up yet.

Hello, @sublimedesigns,

I checked your website Dashboard It seems that you have not given Admin Level privilege. I logged in into your WordPress Dashboard I could not able to find the plugin and theme setting since you have not given Admin privilege to this account that you have given to us.

Please recheck and send us again with Admin level privilege.

Your given development sever login details are not working. I tried with same credentials as you mentioned, unfortunately, it is not working at my end.


Hi Prakash,

I had disabled it after a few days. Have enabled it again.

Hello @SublimeDesigns,

I have logged in and checked your slider version. I went ahead and updated it to 6.2.22.
The slider should work now.

see the secure note.


Hello Ruenel,

Thank you for updating. the slider works now.
However, I can not replicate the same with the live version.
Please let me know what I need to do to get it working in the live version.

Thanks for the support.

Hey @sublimedesigns,

Slider Revolution is still on version 6.2.21 on your site. I don’t see an update notification though so you need to manually update by uninstalling Slider Revolution then installing it again via X > Validation.

I’d recommend you back up or export all your sliders first so that you’ll have your slider data with you in case something goes wrong.

Hope your slider works after updating to 6.2.22.

Hi @SublimeDesigns,

Your post reply has been withdrawn. You may have updated to 6.2.22 version and resolved your issue already.
If you need anything else we can help you with, don’t hesitate to open another thread.


Hello Ruenel,

Yes I did withdraw the reply.
I received a panic call from my client at 2:30 AM, which was a response to a panic call they received from one of their friends, saying that the website is a heap of mess. I woke up and checked and… indeed it was. A total mess. All the customisation was gone and the page content was all over the place, styling was toast and nothing seemed to be in place.

While I guessed that someone from your team might be checking it out or updating it, and I asked them to calm down, and decided to wait for a few minutes. Well, It was still in a total mess even after a while. I then saw the message here from @christian. It was quite a while by then but the website was still in a mess. I then decided to restore it and realised all the custom coding was still there but somehow not being executed. It took me a few minutes to figure that someone had enabled the parent theme and forgot to revert to the child theme. By then I there was a lot of exchanges between me and my client and I was in a different state of mind. I had to delete a couple of replies because they weren’t exactly peaceful.

Yes I have updated the slider but that was an automated update of what you did in the dev portal, but I am yet to use the slider in the website. However, I am still getting errors in the Google search console that weren’t there before. I’m still trying to figure that out.

Hey @sublimedesigns,

Please clarify if the slider is now working in your live site and also give us a screenshot of the search console errors so maybe we could tell if it’s coming from our theme.


This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.