Error when login into dashboard

Hi there,

I cannot access my webpage admin dashboard. It shows me the following error:

Warning: Cannot modify header information - headers already sent by (output started at /home1/heikeeco/public_html/heikeeco/wp-content/themes/x-child/functions.php:1) in /home1/heikeeco/public_html/heikeeco/wp-includes/pluggable.php on line 1216

I am not sure why. Would love and appreciate your help.

Kind Regards,
Heike

Hello Heike,

Thanks for writing in! This error usually occur if you have modified the contents of the functions.php file. Please login to your ftp and browse to the theme’s folder wp-content/themes/x-child/ and edit the functions.php file. The content must have this code:

<?php

// =============================================================================
// FUNCTIONS.PHP
// -----------------------------------------------------------------------------
// Overwrite or add your own custom functions to X in this file.
// =============================================================================

// =============================================================================
// TABLE OF CONTENTS
// -----------------------------------------------------------------------------
//   01. Enqueue Parent Stylesheet
//   02. Additional Functions
// =============================================================================

// Enqueue Parent Stylesheet
// =============================================================================

add_filter( 'x_enqueue_parent_stylesheet', '__return_true' );



// Additional Functions
// =============================================================================

If still nothing is working, please provide us the actual contents of your child theme’s functions.php file in your next reply.

Regards.

Hi RueNel,

Thanks so much for this info. It took me a while to figure out how to access the files through bluehost but got there in the end so thank you :slight_smile:

Cheers,
Heike

You’re welcome, Heike. Glad we could help.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.