Error Updating Pro 1.1.0 to 1.2.7

Hey Team,

we just updated to Pro 1.2.7 from version 1.1.0. (I know there is version 2.0 by now).

When updating we always have this error and we can’t enter the backend - and the frontend is destroyed:
Fatal error: Uncaught Error: Call to undefined function x_set_view() in /kunden/239340_70794/rp-hosting/9876/10877/campussite/wp-content/themes/pro/framework/functions/pro/bars/setup.php:41 Stack trace: #0 /kunden/239340_70794/rp-hosting/9876/10877/campussite/wp-includes/class-wp-hook.php(286): x_bars_setup_views(’’) #1 /kunden/239340_70794/rp-hosting/9876/10877/campussite/wp-includes/class-wp-hook.php(310): WP_Hook->apply_filters(NULL, Array) #2 /kunden/239340_70794/rp-hosting/9876/10877/campussite/wp-includes/plugin.php(453): WP_Hook->do_action(Array) #3 /kunden/239340_70794/rp-hosting/9876/10877/campussite/wp-includes/template-loader.php(12): do_action(‘template_redire…’) #4 /kunden/239340_70794/rp-hosting/9876/10877/campussite/wp-blog-header.php(19): require_once(’/kunden/239340_…’) #5 /kunden/239340_70794/rp-hosting/9876/10877/campussite/index.php(17): require(’/kunden/239340_…’) #6 {main} thrown in /kunden/239340_70794/rp-hosting/9876/10877/campussite/wp-content/themes/pro/framework/functions/pro/bars/setup.php on line 41

Can you try fully deleting Pro and reinstalling? That error would suggest some files are missing and the update didn’t complete successfully. This could happen if the WordPress auto updater is somehow interrupted, or if you had connection issues while updating over FTP.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.