Enviro gallery not showing Lightbox

Hey. I’m having some issues with envira gallery on my main site. For some reason, though Lightbox is enabled, it’s not working. I’ve disabled all other plugins, and have also checked the same configuration of only-network plugins on a sub-site, in which the gallery is working properly.

Confused. Unsure as to what to do next. help?

P.S. - also, I keep getting a nag on the dashboard to activate the enviro plugin license for automatic updates, yet it came bundled with X. How to fix this as well?

Hi there,

Unless we have access to your website and see the case ourselves we will not be able to help to pinpoint the problem exactly, but we can give some general troubleshooting steps:

  1. Ensure everything is up to date according to our version compatibility list here. Please follow the best practices when updating your theme and plugins. Click here for more information.
  2. If you’re using a CDN, please clear the CDN’s cache and disable optimization services.
  3. Remove custom CSS and Javascript from the options or Child Theme and test the case.
  4. You should not use the theme and the bundled extensions as a network install. Try to install them one by one inside each instance.

Unfortunately, the message you see cannot be hidden as it is the default functionality of the plugin, but rest assured that you can ignore that as this is a bundled version and you do not need a purchase key. For more information read the Bundled Version section of the article below:

If you still have the problem kindly get back to us with the URL/User/Pass of your WordPress dashboard using the Secure Note functionality of the post to follow up the case.

Thank you.

Yah what’s weird is that Envira gallery works fine on the sub-sites which also use the X-Theme. I switched over to Pro on the main site yet the issue is still happening. Because they were all using the same Child theme before I switched over to Pro and I wasn’t getting an issue on the sub-sites, I resolved that the custom CSS and such was not the problem.

And, after turning off all the plugins with no success, I am left with confusion. Not currently using a CDN and as far as I know everything is up to date. Again, it works on the sub-sites.

Next step?

Kindly get back to us with the URL/User/Pass of your WordPress dashboard using the Secure Note functionality of the post to follow up the case.


Hi There,

Thank you for the credentials, would you mind pointing us to which page and which Gallery is having the issue? That one on the link below works fine.


Here’s one of the gallery pages

The envira gallery is of the same name (the feminine divine) yet neither it nor any of the other galleries are showing Lightbox.

the link You provided in the last communique opened a blank page.

Hey @Peter_Fae,

The cause of the issue could be incorrect SSL setup that is why resources are blocked. Please correct your SSL setup and check if the issue persists. The page @friech created works because it is loaded http (see Secure Note).


My apologies for busting in on this thread, but I suspect I might have the very same problem - and possibly the same solution would apply.

Christian - could you please have a look at this thread?

@adsparksa, looks like it’s okay now :slight_smile: Cheers!

The issue is not resolved. I have SSL enabled on the site through wpengine, yet I do not understand what is causing the problem

Hello There,

I have created a test in my local install using a default setting. The output of your Envira gallery is different from my output. The images on my grid can be clickable and in your site it is not and just a plain image. Somehow the image link has been removed. This can be caused by a setting or a plugin. Could you please test for a plugin conflict. You can do this by deactivating all third party plugins, and seeing if the problem remains. If it’s fixed, you’ll know a plugin caused the problem, and you can narrow down which one by reactivating them one at a time.

Please let us know how it goes.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.