Drop down menu not working on mobile since update

Hi, my drop down menus aren’t working on mobile since the update. On desktop, you can hover over the menu for it to display the drop down links, but on mobile, if you click the down arrows, it takes you to the main link instead of displaying the drop down links. How do I fix this?

I’ve already cleared caches through the WPEngine Dashboard and the styling cache of Theme X itself but that didn’t work


Site URL - https://barbellrehab.com
Home URL - https://barbellrehab.com

WordPress Environment

Version - 5.3.2
Debug is on - No
Language - en_US
Is Multisite - No
Memory Limit - 512M

Web Server Configuration

Software - Apache
PHP Version - 7.3.14-6+ubuntu18.04.1+deb.sury.org+1
MySQL Version - 5.7.28-31-log

PHP Configuration

Post Max Size - 100M
Time Limit - 0s
Max Upload Size - 50M

Active Theme

Name - X – Child Theme
Version - 7.2.0
Folder - //nas/content/live/barbellrehab/wp-content/themes/x-child/
Parent Theme Name - X
Parent Theme Version - 7.2.0
Parent Theme Folder - /nas/content/live/barbellrehab/wp-content/themes/x
Cornerstone Status - Enabled
Cornerstone Version - 4.2.0

Active Plugins

Must-Use Plugins

  • WP Engine System 3.2.3
  • Force Strong Passwords - WPE Edition 1.6.4
  • WP Engine Seamless Login Plugin 1.5.3
  • WP Engine Security Auditor 1.0.8

Caching Plugins

  • Autoptimize 2.6.2

Other Plugins

  • a3 Lazy Load 2.3.1
  • ActiveMember360 3.1.4
  • Akismet Anti-Spam 4.1.3
  • Autoclear Autoptimize Cache 2.0.0
  • Cornerstone 4.2.0
  • Google Tag Manager for Wordpress 1.11.2
  • Insert Headers and Footers 1.4.5
  • Post Duplicator 2.20
  • Really Simple SSL 3.2.9
  • Redirection 4.7
  • Related Posts for WordPress 2.0.3
  • ShortPixel Image Optimizer 4.16.2
  • Smart Slider 3 3.3.27
  • Thrive Leads
  • Thrive Product Manager 1.2.2
  • TinyMCE Advanced 5.3.0
  • WooCommerce Stripe Gateway 4.3.2
  • WooCommerce 3.9.2
  • Yoast SEO 13.1
  • WP Mail SMTP 1.8.1
  • WP-Sweep 1.1.1
  • WPForms Lite


Click this button to check what CDN this site is using. - Check CDN

I’ve also tried disabling Autoptimize and re-clearing the server cache but am still having this issue.

Hey Michael,

There’s a conflict with a script. Please check Theme Options > JS and temporarily remove all the codes in there. If the issue persists, try activating the parent theme and give us WordPress Admin access in a Secure Note


see secure note above.

Hello Michael,

We cannot give you any email since we have several staff working 24/7. I would recommend that you use any email and send the WP credentials so that we can log in and investigate your issue as soon as possible to get this resolve.

Meanwhile, please regenerate your minified HTML, JS and CSS files.


ok. I’m unable to regenerate my minified HTML, JS, and CSS right now because I don’t know how and will need to contact my developer about it. In the meantime, if you’re able to proceed forward without me doing this, please go ahead.

Ok, I actually did what you asked by clearing Autoptimize cache and the cache on the server end too.

Hello Michael,

The sub menus is working on my end.

You will have to delete the Autoptimize cache and then your browser cache as will before testing your site again.

Kindly let us know how it goes.

Hi, I’ve cleared the Autoptimize cache and browser cache but it’s not working for me on IOS Safari or IOS Chrome. I’ve also tried it on two separate IOS phones too.

Hi Michael,

I was able to replicate the issue that you have mentioned. The default function of the mobile dropdown is that when you click on the down arrow icon, it will show the sub menu. However, on your website, tapping on the sub menu links to the page of the menu item.

This might be because by a custom script that you have added on your website. I checked your child theme are there some customization scripts added to the function.php of the child theme?

Have you tried temporarily getting rid of all the codes you have added there and seeing if the issue persists?

Please let us know how it goes.

I have not tried temporarily getting rid of the codes, I’d rather not if I don’t have to. The mobile drop down and sub menus were working fine before the update on 2/28 to Theme X 7.2, so I’m just wondering why there’s an issue now all of a sudden?

The only customized scripts I’ve recently added were from rows 294-409 in the function.php child theme. I just tried deleting them and clearing the cache and am still getting the issue with malfunctioning submenus on mobile.

Hello Michael,

Sorry, but I can’t replicate the issue on my end, most of the time this inconsistent issue is caused by a caching, please clear your Autoptimize and deactivate it for a while, and all other caching features on your site.


Hi Michael,

I have an iPhone XR and tested your website and could not replicate the issue. I opened up the menu using the hamburger menu icon, and tapped on the double-down arrow and it opened the sub-menu items:

I used the Services menu item. I asked @jade who replicated the issue and she also now can not replicate the issue and can open up the sub-menus, here is the video of her device:

The device is iPhone 6.

Thank you.

Hi, yes, because I had to do a workaround for it to work. If you make the main link a custom “dummy” link (aka it doesn’t point to anywhere) then it will drop down on mobile like it’s supposed to. However, if the main link actually points to a webpage, the issue persists. If you click on the down arrows, the menu will not drop down and it will, instead, take you to the link. This isn’t ideal, as I want the main link to still point to a webpage, but I chose to do this workaround instead for the time being.

updating to Theme X Ver. 7.2.1 just fixed it. Thanks

We’re happy to hear that the update fixed the issue.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.