Drop Down Menu Links are not Clickable

I decided to remove the traditional headers and put the inline navigation modal on every page. Since doing that, the links that drop down from the menu do not work. I have deactivated plugins and updated software but nothing is working. Please advise.

Hello @SDCreativeWorks,

Thanks for writing to us.

I tried to access your site dashboard since your site is in maintenance mode but your site dashboard URL is not accessible due to your security plugin or setting. I would suggest you disable the security so that we can check it at our end. I would suggest you troubleshoot a few of the common issues before we investigate your settings.

  1. Testing for Plugin Conflict
  2. CSS/JS Customization
  3. Version Compatibility
  4. Disabling Cache
  5. Child Theme

Hope it helps

It is disabled now.

Hello @SDCreativeWorks,

We are still unable to login because WordFence plugin is locking us out.

By the way, I have inspected the page and I found out the reason why you cannot click on the submenu items. You are using columns where you have inserted the Navigation Inline element. Be advised that the Column element will have the overflow hidden away. This is why as you scroll the submenu and get pass the height of your column, the submenu get hidden away.

Since you are using the Pro theme, simply go to Cornerstone > Header Builder and create a custom header instead. With the custom header, you will be using the Bar element which is suitable for headers and navigations.

Perhaps the video tutorials from our Youtube Channel can help you as well:

Best Regards.

I understand what you’re saying. My issue comes with making the traditional navigation background transparent. I’m not the most skilled person in regards to coding but when I select the color of the background to be CLEAR or Transparent, it still shows white. This client wants a transparent background. Can you help me with that?

Hi @SDCreativeWorks,

The WordPress admin is still not accessible and showing the same error. Still, I investigate your website through the browser inspector tool and found that the Row under the Navigation is overlapping the Submenu items. I would suggest you set the z-index of the Row to 0 to get rid of this issue. I have tried by setting the value using the debugger tool and it worked.

Hope it helps.

My apologies and I appreciate your patience thus far. I deactivated Wordfence.

Also, I did change that number to 0 but the result is still the same at this point. I’m going to try and add the traditional header back and see if it makes a difference. I look forward to your reply.

Hey @SDCreativeWorks,

The recommendation given my colleague was correct but there’s a default CSS from the integrity stack overriding the settings. I suggest that you add the code below in your Classic Row (v2) 3 > Customize > Element CSS

$el {
  z-index: 0 !important;

Please note that custom CSS code is outside the scope of our support. Issues that might arise from the use of custom CSS code and further enhancements should be directed to a third-party developer or you can avail One where we can answer questions outside of the features of our theme.

Hope that helps.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.