Different Host same domain Cornerstone not activating license

I paid for one license. I recently changed hosting for my domain. I migrated the website via cpanel and myphpadmin. I can login to WP on the new hosting but i get the prompt that cornerstone license is not validated. When i try to input the purchase code i received, I get this error;
“We’ve checked the code, but it doesn’t appear to be an Cornerstone purchase code or Themeco license. Please double check the code and try again.”. I have tried the following;

  1. List Deactivating and reactivating the theme: I still get the same error
  2. Reinstall Cornerstone manually via FTP: I still get the same error

NB: I’ve checked the forum for similar questions and none of the suggested solutions have worked for me.

I’d appreciate any assistance.

Hi Kelvin,

You shouldn’t be activating Cornerstone. You should activate the theme as your license is for the theme.
Please check the link below for your guide.


Thank you for the link. I have checked in the validation section and i get the message “Your site is validated. Revoke validation.” and above it there is “NOTE: A separate license is required for each site using X. Each X purchase includes a Cornerstone license.” however everytime i try to load Cornerstone or Theme Options i get this error "[an error occurred while processing this directive]"

Hi Kelvin,

I can see the issue. You do have updated Cornerstone but X theme is not updated. See our changelog for X 6.5.6 and Cornerstone 3.5.5. I can see update for X theme is not appearing on the notfication. Please download it from your dashboard here instead. Then see this guide on how to update. It is important that you are using both updated X theme and Cornerstone to avoid incompatiblity issues.

Hope this helps.

I have updated the theme using 2 different methods as detailed in the article you shared;

  1. Via FTP
  2. Via Wordpress Dashboard

and still i’m getting the same error when i select Cornerstone. "[an error occurred while processing this directive]"

How can i know if my settings meet the minimum requirements of the X Theme? i don’t see any options within the Theme dashboard.

I managed to solve the problem. It appears to have been a cache issue. Everything is working well now. Thanks for the help.

Glad to hear that. :slight_smile:

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.