Design Cloud Problem - Restaurant Demo

Hi Guys cant install the “Restaurant” Demo from Design Cloud.

I have already followed the advises on Can't install Gym template from Design Cloud

Thanks for your support! Any good hints are welcome.

Hey @ritbonn,

Thank you for reaching out to us. There could be a different reason of your issue, please perform the following troubleshooting steps and see if this resolves the issue:


If you still have problems then please get back to us with the result of the steps above and URL/User/Pass of your WordPress dashboard using the Secure Note functionality of the post to follow up the case.


Hello @ritbonn,

I have checked your site and everything seems in order. Your WP core, plugins and theme is up to date. Your PHP memory and other server setting are good. When I import the Restaurant demo, it seems that it is stuck:

Nothing is thrown in the console which can give us a hint of what is going on. Please check on the following:

  • Worked through the cURL solutions
  • allow_url_fopen is on
  • OpenSSL support is enabled

Check with your hosting provider. Maybe the timeout is being thrown by Apache. You could try increase TimeOut directive (see

Kindly let us know how it goes.

Hi @ruenel,
i am getting the same result when it try to install the demo.

  • allow_url_fopen is on

What is the cURL solution?
How can i check if OpenSSL ist disabled?

Hello @ritbonn

Please consult to your web host (hosting provider ) set allow_url_fopen, cURl and OpenSSL for all these server settings.


We have checked everything.

curl, allow_url_fopen, and Openssl.

What should we try next?

Hi @ritbonn,

It seems that mod_security is enabled in your site, and that causes the issue you are having. It not let you call the Cornerstone endpoint to import the Design Cloud assets.
I would suggest you contact your hosting service provider to temporarily disable the ModSecurity for you and make the Cornerstone endpoints whitelisted.

Hope that will resolve your issue.

Mod Security is not even installed.

Hello @ritbonn,

There might be a few different reasons for this issue in order to further investigation, please provide login credentials for your site in a secure note to examine it further, including:

– WordPress Site URL & Admin URL
– WordPress Admin username/password

To create a secure note, click the key icon underneath any of your posts.


This is the staging environment. There is nothing important on that site.

Hi @ritbonn,

We just check your staging area and there’s no error in the console log for the hint to solve the issue. I recommend you to set the MYSQL configuration that might help us to sort your issue.

Recommended MySQL configuration

max_allowed_packet = 16Mb
innodb_log_file_size = 128mb

Hope that helps and let us know how it goes.

Thank you.

1 Like


in my.cnf did the trick.

Thank you

Hi @ritbonn,

We’re glad that it helps you to solve your issue. If you have any other concerns, feel free to reach us.

Thank you.

1 Like

Hi @ritbonn,

Can you check the console log if there’s an error? If you didn’t know how to open the console just press the f12 and let us know how it goes.

Hope that helps.

Thank you.

Hello @ritbonn,

According to your screenshot, there is some JS console error because of that the when you are importing the demo the media files are not importing properly. It might be the issue of plugin conflict or ModSecurity issue. You can check for plugin conflict. Can you please contact your hosting providing and ask them to temporarily disable your ModSecurity? You may need to whitelist Cornerstone-endpoint as well. After doing this server setting please try to import the demo.

In case if doesn’t work

  1. Log into your cPanel dashboard.
  2. Using the file manager, navigate to your WordPress site’s root directory.
  3. Locate and open the .htaccess file for editing.
  4. Add the following line of code at the top of the file:
  6. Save the changes to the .htaccess file.

If you are not using a cPanel based host skip to step 3 and use FTP then look for the .htaccess file in your websites root directory then add this into your SetEnv MAGICK_THREAD_LIMIT 1 .htaccess file.

If all the above doesn’t import demo then, please share your details in a secure note. Please provide the following details

  • WordPress Login URL of the new domain
  • Admin level username and password of your new domain
  • FTP details of the new domain

You can find the Secure Note button at the bottom of your posts


sorry! it didn’t work out!

Hello @ritbonn,

Thanks for sharing the FTP and login credentials but unfortunately your WordPress login details are not working. Please recheck and send us again.


sorry i have corrected that

any idea so far?

Hello @ritbonn,

When I check your site, it seems that the Restaurant demo is already installed. I just have to reassign the pages in Settings > Reading > Front Page Displays so that the home page and the blog index display the correct pages.

Kindly check your site now.