Deactivate comment function on blog

Hey there,
I’d like to disable commenting.
Thanks for your help!


Please navigate to Settings > Discussions > uncheck Allow people to post comments on new articles option:

Hope it helps :slight_smile:

you did not understand me: I’d like the entire comment section to be not visible!


If you have done the suggestion made by @thai and the comment section in the posts are still active, you will have to go over the posts and disable the discussion option as those are enabled by default since the comment option was enabled previously.

#1. Go back to the posts and edit one of them then click on Screen Options which is on the top right area of the page just below your username.

#2. Enable the Discussion option.

#3. Scroll down the page and you should see the Discussion metabox and the Allow comments option under it.

#4. Disable Allow Comments.

If the issue persists, please provide us with the admin access to your site in a Secure Note:

added secure note


Since you’re using Gutenberg, you can access the Discussion meta options from Settings.

You can learn more about Gutenberg controls at

Hope that helps.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.